2
\$\begingroup\$

I'm trying to make a headset with microphone (and stereo audio) for an Android phone. The headset will be connected to a 3.5 mm TRRS jack. I have read the specifications for such devices from Android Source. My schematic with working buttons is:

schematic

simulate this circuit – Schematic created using CircuitLab

The "mic" resistor is the dummy microphone I used before I received the real microphone (real microphone's output impedance is 2.2 kΩ). I have named the switches according to the functions A...D and calculated their corresponding resistances based on the equations from Android Source (the values shown in the schematic are measured resistances.) This schematic works and I get pushed buttons to work as described: Answer call, volume up/down and "voice control".

The problem comes when I added the real microphone (mic specs) and removed the dummy resistor. New schematic:

schematic

simulate this circuit

For the microphone connections, I used the schematic ("measurement circuit") provided in the microphone data sheet.

  • After adding the microphone to the circuit, all the buttons stopped working but the microphone works.
  • If I added the 2.2 kΩ dummy microphone to the circuit with the real microphone, the buttons start working but the microphone stops working or at least no sound comes from the speaker. (Maybe not enough current?)
  • I have tried removing capacitor C1 with the dummy "mic" and just connected microphone straight to MIC-line and removed the external bias voltage and R5. The buttons work, microphone doesn't.

I have measured the microphone to ground (microphone bias voltage?) voltage of my phone and it is only 0.825 V instead of the 1.8-2.9 V specified at Android Source, for some reason, but I do provide the external bias voltage for the microphone.

The speaker I used is just some 32 Ω cut from a handsfree ear button set.

Is this something obvious that I'm missing here? Would I just need some amplification of the microphone with an op amp to get it working with the buttons even if the sound is loud enough without the buttons working?

I do have some low power op amps coming but would like to know if there is something else in my circuit that is the fault here.


EDIT: Actually, my phone gives out 1.77 V after it has detected microphone and then removed the load and measured. The other phone gives constant 1.77 V all the time even without previous detection of load.

Found the problem, it was latching button. The buttons I bought should have been non-latching but doesn't seem so. So the hardware buttons can't be pressed at the same time when using the microphone at least with this schematic. I wonder how they make those PTT headsets work?

\$\endgroup\$

2 Answers 2

0
\$\begingroup\$

Ignore the buttons for now.

Connect the mic directly between MIC and GND.

If the mic does not work properly then it's not compatible.

Based on datasheet it requires 3V bias to operate within specs, so it might work poorly with the nominal 2.2V bias from the phone.

Order a mic with smaller bias voltage requirement.

\$\endgroup\$
1
  • \$\begingroup\$ Ignoring the buttons helped finding out that they were latching even when they were not supposed to and this made the circuit not working. \$\endgroup\$ Oct 21, 2022 at 11:12
1
\$\begingroup\$

Your second diagram is incorrect. You do not need C1, R5, or the battery. Just install the microphone capsule in place of the "Mic" resistor in your first diagram. Watch the polarity.

The Android phone provides the bias voltage and an appropriate series resistor. Headsets do not normally include a battery - yours should not need a battery, either.

Measure the microphone line from the phone. Without a microphone connected and all buttons open, it should read close to 2.2VDC. If not, you have another problem either in the wiring or in the phone.


The resistor values given in the Android specifications assume a microphone impedance of 5k. Your microphone has an impendance of 2.2k - you will have to recalculate the values.

Refer to this chart from the Android specifications:

enter image description here

For example, you will have to calculate R2 such that the value of R2 in parallel with the microphone impedance gives 240 ohms. That works out to 269 ohms for R2.

\$\endgroup\$
7
  • \$\begingroup\$ I have tried this already, the microphone works, recording quality is worse than with the C1 and sound is not as loud and the buttons don't work. \$\endgroup\$ Oct 21, 2022 at 8:27
  • \$\begingroup\$ Tried this again and the buttons actually do work (have to have had some error in the past), but the microphone doesn't. \$\endgroup\$ Oct 21, 2022 at 8:42
  • \$\begingroup\$ I have calculated the values of the resistors and they are shown in the wiring diagrams. The microphone to ground is 0.825 V as stated. That might be the issue then? \$\endgroup\$ Oct 21, 2022 at 8:51
  • \$\begingroup\$ If you disconnect all of your circuit from the microphone and measure the voltage from the microphone line to ground and only get 0.8V, then there's something wrong. \$\endgroup\$
    – JRE
    Oct 21, 2022 at 8:54
  • \$\begingroup\$ Is it any good to try to amplify this voltage, would it possibly solve the issue rather than getting new phone? \$\endgroup\$ Oct 21, 2022 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.