0
\$\begingroup\$

So I made this minimal esp32-S3(ESP32-S3-WROOM-2-N32R8V) custom board just to try out OTG feature. Major parts include a usb type-c, a LP3875 LDO, and the esp32-S3 module. schematic

After soldering and connect to pc, both LED for 5v vbus and 3.3v were showing light, however no COM port can be found in device manager. I tried the dev kit (https://docs.espressif.com/projects/esp-idf/en/latest/esp32s3/hw-reference/esp32s3/user-guide-devkitc-1.html) and it worked by simply connect to the USB port but not the UART port.

So what did I do wrong? Does the module need to be put in OTG mode first through some other method before it can be connected directly to IO19 and IO20, and then use OTG function? Or is it the problem of my pcb?

\$\endgroup\$
2
  • \$\begingroup\$ I noticed with the development board I had to contact by UART first. Maybe try that. \$\endgroup\$
    – RemyHx
    Oct 22, 2022 at 15:59
  • \$\begingroup\$ @RemyHx hi, for my dev kit, i connect USB straight out of box and it works \$\endgroup\$
    – Yi Fang
    Oct 22, 2022 at 16:05

1 Answer 1

1
\$\begingroup\$

The ESP32-S3 chip needs to be in bootloader mode before it can be detected as a DFU device and flash. This can be achieved by pulling GPIO0 down (e.g., pressing the BOOT button), pulling RESET down for a moment, and releasing GPIO0.

Ref https://docs.espressif.com/projects/esp-idf/en/stable/esp32s3/api-guides/dfu.html

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.