As refereed to my old question ( Connect UART WiFi module to PC ) which has been solved that days, I have a UART Wifi module ( this one ) and unfortunately I have problem again ! The point is, this time I can't remember what's the last configuration of this module.

What I did this time:

1. Connect Power Source: Connect modules VCC and GND to 3.3V external power source.

2. Connect USB to Serial ( with TTL Logic ): Connect module's RX to my converter's TX and TX to RX. (in 3.3V mode, you can see the image of my converter in the end of this question and also Before I connect it, I tested it and it works pretty well with my other circuits. ). I didn't connect converter's ground to module's ground

3. Install terminal program: Install Download and Install Eltima Software's Advanced Serial Port Terminal which I tested this module with it before and it works well.

4. Power up the module and send 3 pluses "+++" after 2 seconds: I power up the module and send +++ with all possible baud rates as a string (or text file) with Eltima, but I don't get the "+OK" as response from the module.

Other attempts:

1- I tried connecting converter's and module's grounds together and tried again with all possible baud rates but nothing happened.

2- I tried 5v mode of my converter but no luck !

3- I tried connecting nReset and nCTS/MODE/GPIO pins to ground for a while and some other blind attempts but no wish...

BTW, when I start my module one of the lights is blinking and the other is just not blinking but is on.

I think I missed something funny here but I don't know what it is. Please help me find a solution to get this module work. I really messed up with it again!

What can I do to get "+OK" from my module after sending "+++" after 2 seconds as a text file ?


simulate this circuit – Schematic created using CircuitLab

This is my USB-TTL converter This is my WiFi module


1 Answer 1


I don't know what to tell you, aside from the fact that you may have put the device into a strange serial mode (maybe you turned on an extra stop-bit, or set it to 7-bit serial).

I would recommend you try the configuration application that the manufacturer provides at the link about your module.

If that doesn't work, it looks like there is a mechanism for forcing it into a "configuration mode", which you can access by tying the nCTS/MODE/GPIO pin high (to Vcc), and restting the module (by connecting nRESET to ground temporarily).

From the manual:

In launching configuration mode, the system ignores the default work mode parameters, and force to operate in the AT+Instruction mode, this mode is commonly used to modify the parameters with the configuration management program and to do the function tests.

Look at section 4.2.1 in the PDF manual.

It's worth noting that if the module is correctly set up to join your network, it may be possible to fix it's configuration by connecting to it via WiFi. All the information about that should be in the manual.

  • \$\begingroup\$ Thank you sir. I successfully enter configuration mode( because LEDs not blinking anymore ) but still cant communicate with the module ( I'm trying both wifi software provided with the manufacturer and terminal prgram ) :( ... about your last note, I should say I don't know the last configuration of this module so I can't connect to it with wifi or any access point. \$\endgroup\$ Apr 2, 2013 at 11:05
  • \$\begingroup\$ I asked another question related to this: electronics.stackexchange.com/questions/64108/… \$\endgroup\$ Apr 2, 2013 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.