0
\$\begingroup\$

Circuit Diagram Hello internet, I stuck at some point while simulating my circuit. This is a circuit that will measure distance and display it on seven segment displays. Firstly, When I tried to simulate this circuit I'm getting these errors;

[SPICE] Gmin step [0 of 120] failed: GMIN=0.001

[SPICE] Gmin stepping failed.

[SPICE] Source step [0 of 120] failed: source factor = 0.0000

[SPICE] Too many iterations without convergence.

Real Time Simulation failed to start.

When I connect an oscilloscope to the 3rd pin of the 555 (U3), the simulation works, but this time I can't get the result I want. I tried to simulate only 555 circuits in another project and they can produce their outputs correctly. I tried to simulate only HCSR04 but I couldn't see anything on the echo pin. Did I make any mistake while connecting some components? Is there a way to simulate the whole circuit?

\$\endgroup\$
4
  • 1
    \$\begingroup\$ Does the HCSR04 even have a simulation model? \$\endgroup\$
    – Hearth
    Nov 27, 2022 at 18:50
  • \$\begingroup\$ yes, it has simulation model \$\endgroup\$
    – Robottur
    Nov 27, 2022 at 19:05
  • \$\begingroup\$ What does Proteus manual says about how to use HCSR04 in a simulation? \$\endgroup\$
    – Justme
    Nov 27, 2022 at 19:06
  • \$\begingroup\$ I don't know, where should I look for the manual? \$\endgroup\$
    – Robottur
    Nov 27, 2022 at 19:17

1 Answer 1

0
\$\begingroup\$

I solved problem about the HCSR04. When I change battery with power pin and remove the resistor at the seven segments upper pins, it is solved but I can't simulate in real time. I'm getting CPU error.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.