0
\$\begingroup\$

enter image description here Circuit reference from Analog Devices

The above circuit produces the correct output in simulations (Proteus and Altium).

When the circuit is built on the board, the first stage produces the correct output, but the second-stage op-amp can't equalize the inputs.

In a test: non-inverting input 20.3 V, inverting input 15.7 V, op-amp output 0.1 V (th is 2.1).

Also used:

  • ISP25DP06NMXTSA1 P-channel MOSFET (Vgs threshold 2.1 V, Rds(on) 250 mΩ).
  • 220 Ω for R3 and 100 Ω for R6 (they are current sense resistors - 1 W).
  • LT1491A op-amp (4-ch).

What is the reason why the second-stage op-amp can't produce the correct output?

\$\endgroup\$
2
  • \$\begingroup\$ What output load did you have? \$\endgroup\$
    – Andy aka
    Dec 17, 2022 at 9:49
  • \$\begingroup\$ 250Ω load resistance \$\endgroup\$ Dec 17, 2022 at 10:04

1 Answer 1

2
\$\begingroup\$

It looks like a bad design from Analog Devices.

The IRF9Z245 MOSFET that drives the output has a maximum gate-source voltage rating of +/- 20 volts. This is the crucial thing to note. Yet, if you don't have a proper load connected, the op-amp output will try and force the gate-source voltage to be -24 volts and that may damage the MOSFET. It's a bad design at the very least as far as I can tell.

The MOSFET you used (ISP25DP06NMXTSA1) also has a 20 volt maximum gate-source voltage by the way. Normally, you would use a zener diode to protect the gate-source region. So, if at any moment in time you ran the circuit without a load you could have fried the MOSFET.

\$\endgroup\$
8
  • \$\begingroup\$ i checked the mosfet, it seems working. also almost all tests done while load is connected. i can check zener diode and high Vgs scale mosfet \$\endgroup\$ Dec 17, 2022 at 13:07
  • \$\begingroup\$ It's still a bad design and, that is an important observation. \$\endgroup\$
    – Andy aka
    Dec 17, 2022 at 13:07
  • 1
    \$\begingroup\$ Confirmed for Zener diode necessary when open load. \$\endgroup\$
    – Antonio51
    Dec 17, 2022 at 13:52
  • \$\begingroup\$ checked with DMP3056L-7 p-ch mosfet and 25V zener diode, but its still same. first stage is working well. but second stage opamp couldnt equalize inputs. \$\endgroup\$ Dec 20, 2022 at 17:43
  • \$\begingroup\$ when i give 3V input the M1 Vgs=-200mV \$\endgroup\$ Dec 20, 2022 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.