I am trying to read back an ALTERA MAX 7000S CPLD (EPM7064SLC84-10) mounted on a board (a part of the board's schematic is shown below) and copy it on another CPLD.

enter image description here In the schematic, X4 is a male 10 pin JTAG port for on-board programming and the big rectangle represents the CPLD. The whole board, including the CPLD, is supplied with a 5V power supply.

After browsing the net, I found this link and this link from the intel community which says the newest software that can support reading and programming this model of CPLD is MAX+PLUS II. Since this software does not support available programmers such as USB BLASTER (based on this link), I had to make a homemade Byte BLASTER programming cable by following the tutorial explained here (The schematic of the made programming cable is shown below.).

enter image description here

JP1 is the 10 PIN female JTAG port.

After installing Byte Blaster driver, I connected the cable via the LPT port to an old PC in which had WinXP and MAX+PLUS II 10.2 installed on it. Next, I connected the programming cable and the board via the JTAG port and then tried to blank check/examine the CPLD, which resulted in the "Unrecognized device or socket is empty" error.

enter image description here

Based on guidance for the same issues in the forums, I tried adding 100pF capacitors for TDI and TDO, checking different modes of LPT in BIOS (SPP, ECP, EPP, EPP/ECP, NORMAL), and reducing the supply voltage from 5 to 3.3 which did not solve the error. It should be mentioned that during performing the examination/blank check command from the PC, I can see the temporary square wave signals on TDI, TDO, and TMS pins with an oscilloscope which shows that a communication is being performed between CPLD and the programming software on PC.

Does anyone have an idea where could the problem be in blank check/examination of the CPLD that causes this error?

  • \$\begingroup\$ How long are your cables from the lpt port to your byteblaster and to the device? Also note that the schematic does not explicitly show 5V connected to pin 20 of the 74ls244 - the circuit will not work without this. \$\endgroup\$
    – Kartman
    Commented Jan 1, 2023 at 23:37
  • \$\begingroup\$ The length of the cable from LPT to Byte Blaster is about 50 cm and the length of the JTAG cable is about 10 cm. 5V and GND pins of 74ls244 (pin20 and pin 10) are supplied via the JTAG port. In order to clarify this point, the schematic was updated. \$\endgroup\$
    – pooya
    Commented Jan 2, 2023 at 5:42

1 Answer 1


After double checking the Byte Blaster ciruit, I found out that pin 19 of the 74ls244 got disconnected from the ground. After fixing this issue the problem was solved. However, I think keeping this question and the links and information I collected from the forums may be helpful for people who want to program/examine old CPLDs.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.