0
\$\begingroup\$

I am using Turkcell operator (2G) in my application (28601). GSM Modem: Telit / GE910QUAD. I use the AT sequence listed below:

AT
AT&F0
ATE0
AT+CMEE=1
AT+FCLASS=0
AT&K0
AT+CPIN?
AT+CGSN
AT+GSN
AT#CCID
AT+GMI
AT+GMM
AT+GMR
AT#SLED=2
AT#E2SLRI=50
AT#TXMONMODE=1
AT#AUTOBND=1
AT+COPS=0,2,28601
AT+CREG=0

And then I query CREG with

AT+CREG?

After a few (searching) responses, it then returns the CREG=3 answer.

Then I query the error with AT#CEER. The command returns Ceer:31. After that, I query the operator via AT#MONIZIP.

The module says: "connected to 28602 (Vodafone) operator". (my SIM is a 28601-Turkcell SIM).

Why does this happen?

\$\endgroup\$
5
  • \$\begingroup\$ first possibility: roaming: your modem does not get (sufficient) connectivity to turkcell's network, and automatically roams to the vodafone network that in your location has better reception. This can be 100% transparent (and cost-free to you), or not. Depends on how that is regulated. Second possibility: your modem needs to be explicitly told that it should use a specific network mode; AT+WS46=12 would enforce GSM only, which would imply circuit-switched data (horribly inefficient; it's possible turkcell just turned that off). \$\endgroup\$ Commented Jan 2, 2023 at 10:36
  • \$\begingroup\$ Assuming this is a low-power application, you'd want AT+WS46=39 instead, is my guess: 5G, 4G or EDGE (which people slightly confusingly call "2.5G"); you really don't want pure 2G for a data device. \$\endgroup\$ Commented Jan 2, 2023 at 10:37
  • \$\begingroup\$ So: first thing to check whether your device actually does get turkcell connectivity. It simply might not – wrong antenna for the bands that are used, or simply hardware not able to use these, or simply bad location. Maybe also your SIM card isn't allowed to connect! (subscription needs to be externally activated first, or subscription simply not valid) The fact that you get "searching" statuses really suggests you simply can't connect to turkcell's infrastructure. \$\endgroup\$ Commented Jan 2, 2023 at 10:38
  • \$\begingroup\$ i control the parameter list by "AT+WS46=?" but modem allows only 12 for WS46 command. And I try it but nothing changed. :( \$\endgroup\$ Commented Jan 2, 2023 at 11:28
  • \$\begingroup\$ Then, as said, check whether your operator actually offers pure, non-EDGE, 2G in your location. \$\endgroup\$ Commented Jan 2, 2023 at 11:36

1 Answer 1

0
\$\begingroup\$

Maybe the network has taken down GSM and would only respond to CGREG or CEREG instead of CREG: https://stackoverflow.com/a/71207864/2103990

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.