0
\$\begingroup\$

Following the official schematic and guideline (AN738: Si4825/36-A Antenna, Schematic, Layout, and Design Guidelines), I am building a Si825 A10-based radio receiver.

I am getting weak audio output even with an audio amplifier, but band selection and tuning are still not working. I am using a 470 kΩ pot and spare resistance for band selection, as I do not have access to the exact value for the resistance.

Is it possible to achieve band selection using the above parts?

Schematic for band selection

\$\endgroup\$
3
  • \$\begingroup\$ refer to the document that is mentioned in the datasheet section 4.6. Band Select \$\endgroup\$
    – jsotola
    Jan 9, 2023 at 17:52
  • \$\begingroup\$ Have referred to the guideline, not very clear to me as I am new to electronics. \$\endgroup\$
    – digiwizkid
    Jan 9, 2023 at 17:56
  • \$\begingroup\$ With pins 10 and 11 grounded then you use the volume control on the audio amplifier to control loudness. \$\endgroup\$
    – Audioguru
    Jan 10, 2023 at 1:20

1 Answer 1

0
\$\begingroup\$

Since band selection is not working, have you verified both your connections for TUNE1 and BAND? In the schematic the TUNE1 connection is shown using logical connectivity with labels instead of showing a physical line. Easy to read, but if you are new it is even easier to overlook.

The weak audio output could be a lot of things. Fix the band selection and then check your grounds.

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.