0
\$\begingroup\$

I just bought a NEMA 17 motor and some DRV2285 drivers and am following this tutorial.

Originally, the problem was that the stepper motors weren't turning, only vibrating. I was able to adjust the voltage using a multimeter. Now, all my voltage values are reading zero from the motor driver. I verified that my multimeter wasn't the culprit by checking my 12 V, 2 A power supply that I'm using to power my driver. Now, the stepper motor won't turn too. How do I get my stepper motor working? Any help would be appreciated.

Here is the code I am using:

// Include the AccelStepper Library
#include <AccelStepper.h>

// Define pin connections
const int dirPin = 5;
const int stepPin = 4;

// Define motor interface type
#define motorInterfaceType 1

// Creates an instance
AccelStepper myStepper(motorInterfaceType, stepPin, dirPin);

void setup() {
    // set the maximum speed, acceleration factor,
    // initial speed and the target position
    myStepper.setMaxSpeed(1000);
    myStepper.setAcceleration(50);
    myStepper.setSpeed(200);
    myStepper.moveTo(200);
}

void loop() {
    // Change direction once the motor reaches target position
    if (myStepper.distanceToGo() == 0) 
        myStepper.moveTo(-myStepper.currentPosition());

    // Move the motor one step
    myStepper.run();
}

I am using the wiring shown in the article I linked above, except my DIR pin is in pin 5, and my STEP pin is in pin 4 because pins two and three are being used:

wiring diagram

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Why have you defined the pins as 4 and 5 but connected 2 and 3? \$\endgroup\$ Jan 25, 2023 at 23:36
  • \$\begingroup\$ Red green yellow blue is unusual for a stepper. All of mine are red blue green black. Maybe your wires are mixed up? Can you use a multimeter to check the DC resistance of each pair of wires? If your wiring's right, measuring red and green should be less than 10 ohms. \$\endgroup\$
    – Matt S
    Jan 25, 2023 at 23:45
  • \$\begingroup\$ My wires are red blue green black too. The diagram on the website just says red green yellow blue. I used a multimeter and switched the two middle wires(blue and green) after the motor stopped vibrating all together. Now I think I have the correct wiring, but the motor will not turn in any wiring configuration. Did I blow my motor? I tested all five of my drivers and none of them make the motor vibrate anymore. \$\endgroup\$
    – 3DCoded
    Jan 26, 2023 at 11:37

1 Answer 1

0
\$\begingroup\$

This morning, I changed the driver and it worked!

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Did you change anything else from your original setup? Your previous comment implied that you already tried changing drivers. \$\endgroup\$
    – Matt S
    Jan 26, 2023 at 22:04
  • \$\begingroup\$ "I tested all five of my drivers and none of them make the motor vibrate anymore." Are you saying that all of those 5 drivers were damaged, and the existing setup with a new driver worked? If so, can you explain what could have damaged those drivers? \$\endgroup\$
    – Velvet
    Jan 27, 2023 at 7:06
  • \$\begingroup\$ I did try using 24V at 4A on some of them, which may have damaged them. I also accidentally shorted out some of the pins when trying to adjust the potentiometer with a screwdriver. These were also cheap drivers, so that could have played a part. One of them had a hole in the chip and started smoking... \$\endgroup\$
    – 3DCoded
    Feb 10, 2023 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.