0
\$\begingroup\$

I'm not a super-expert of oscilloscopes but I used several Tektronix (both analog and digital.)

I have a Hantek DSO4254C and I'm not able to get it to trigger on a sine wave coming from my board. The signal has a frequency of 300 Hz and an amplitude of about 3.6 Vpk-pk. CH1 is set to DC, the trigger is set to rising edge and automatic mode and the trigger level is about one half of the signal:

enter image description here

The waveform bounces around the X axis continuously, so I tried to set the mode to manual and I discovered it does not trigger. If I manually force the trigger, every time the waveform is shown in a different location (like the auto mode does).

Why is the trigger not triggered? What other settings should I tune?

The only way I found to get a "quite" stable waveform (even if not perfect) is to use the slope type of trigger. That means I have to define two thresholds. That seems to be overkill to me for such a simple signal.

\$\endgroup\$
4
  • \$\begingroup\$ Manual trigger means it triggers the moment you press the manual trigger button, regardless of what's going on with the voltage. So of course it would be in a different place every time. \$\endgroup\$
    – Hearth
    Feb 1, 2023 at 14:29
  • \$\begingroup\$ Haven't used Hantek but have you either scrolled to the right too far or is there any advanced setting on the tigger (delay for instance) on the second page of the trigger menu? \$\endgroup\$
    – winny
    Feb 1, 2023 at 14:58
  • \$\begingroup\$ DSO4000 Series Digital Storage Oscilloscope User Manual \$\endgroup\$ Feb 1, 2023 at 16:47
  • \$\begingroup\$ What other trigger modes you have than "auto" and do they solve your problem? \$\endgroup\$
    – Justme
    Feb 1, 2023 at 17:16

1 Answer 1

1
\$\begingroup\$

I don't have that HANTEK model, but trigger setups are fairly common across the oscilloscope universe.

First, for such low frequencies, you need not use the full bandwidth available. Many 'scopes allow you to limit bandwidth. My 200MHz 'scope allows a 20MHz bandwidth limit to be set. Limiting bandwidth will cut high-frequency noise (especially spikes) that confuse trigger circuits.

Next, go to the trigger menu, and look for Noise reject or High-frequency reject. These will both make triggering less "hair-trigger".

I tried to setup a noisy waveform similar to OP's. With full bandwidth, and NORMAL sweeps, with DC trigger. Persistence was set for a few seconds, so you can see how some overlaid sweeps have mis-triggered. Triggering was confused because it saw some noise spikes that met the trigger-level requirement, but noise spikes caused the slope requirement to be momentarily wrong: full-bandwidth, mis-triggered


After turning on BW limit 20 MHz , and setting HF reject , triggering settled down consistently. Noise reject on the trigger menu gave the same acceptable result:

with HF reject

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.