0
\$\begingroup\$

I'm using this MOSFET driver IC.

Below is the schematic of the high side:

enter image description here

I followed figure 6-3 and 6-5 for the ICs schematics connections.

I have not populated the LED branches off of the gate outputs on all of the drivers (high side and low side). One thing I noticed in capturing this data was that the Vboost signal starts where it is supposed to be (~37V) but then drops down to near system voltage (~24V) and never recovers to what it should be after the first pulse. This seems to me to be the root of this issue however I am not sure how to address it. I would imagine that the voltage at the Vboost pin should recover back up to the ~37V it was before the input pulses started.

These screenshots were taken with a 2.7nF boost capacitor. I had tried the configuration previously mentioned with 10nF as the boost capacitor connected to Vdd. The first few cycles were elevated but they decayed quickly to the system voltage (i.e no boost). So it looks like it helped a little with the boosting but ultimately decayed in the same way the 2.7nF boost capacitor did.

I have noticed that while this circuit runs in its current state, the high side MOSFET is getting warm quickly during operation, likely due to a weak turn on voltage not turning the MOSFET on all the way.

There is a drawing to show the voltage across the load. I am currently using a 1.8 ohm resistor to simulate the load that will be present in the final application, a 24VDC brushless DC motor. Since it is a 1.8 ohm resistor, the load current was determined by dividing the voltage pulse amplitude by the resistance. Since the signal is ~50% duty cycle the practical current would actually be half of that calculated result.

enter image description here

enter image description here

enter image description here

\$\endgroup\$
11
  • \$\begingroup\$ I think you've picked the wrong chip for the job. It won't work at 37 volts with bootstrapping and, you need bootstrapping to get what you want. \$\endgroup\$
    – Andy aka
    Commented Feb 10, 2023 at 8:55
  • \$\begingroup\$ Could you please explain a bit more clear on why it won't work @Andyaka \$\endgroup\$
    – user220456
    Commented Feb 10, 2023 at 8:58
  • \$\begingroup\$ Do you understand what high-side bootstrapping of MOSFETs achieves? \$\endgroup\$
    – Andy aka
    Commented Feb 10, 2023 at 9:05
  • \$\begingroup\$ Yes @Andyaka, this IC seems to have internal charge pump and provides the Vboost pin to add a bootstrap capacitor, right? \$\endgroup\$
    – user220456
    Commented Feb 10, 2023 at 9:10
  • \$\begingroup\$ Yes but your circuit isn't using a bootstrap circuit. \$\endgroup\$
    – Andy aka
    Commented Feb 10, 2023 at 9:12

1 Answer 1

1
\$\begingroup\$

Your circuit is not working because the bootstrap subcircuit cannot do its job. A NMos is enabled once its Gate voltage is higher than its Source, and a boostrap is doing exactly that by building voltage atop the Source. Following your schematic the bootstrap capacitor is not connected correctly, being tied directly to +24V (and not the Source).

Since it seems you are not using a sense resistor and want to connect Sense to 24V, look at FIGURE 6-5 of the datasheet, with one side of the capacitor directly at Source :

Correct connection of the bootstrap diode

A side note of importance: Input a TTL pin and support max +15V, it is not clear whether you connected it directly to +24V.

\$\endgroup\$
11
  • \$\begingroup\$ Thank you for your answer. But since my Voltage is 24V, I have connected the Vboost to Vdd as per figure 6-3? So, which figure should I follow? \$\endgroup\$
    – user220456
    Commented Feb 10, 2023 at 9:43
  • \$\begingroup\$ Could you please clarify on what you meant regarding the TTL pin? I am not able to understand. \$\endgroup\$
    – user220456
    Commented Feb 10, 2023 at 9:46
  • \$\begingroup\$ For the TTL Input, the datasheet specifies : TTL-Compatible Input with Internal Pull-Down Resistor and Input Voltage, VIN -> –0.5V to +15V \$\endgroup\$
    – GCarles
    Commented Feb 10, 2023 at 9:53
  • \$\begingroup\$ Figure 6-3 shows a preferred configuration for supply voltages of 20V to 36V. So there's nothing wrong with tying the boost cap to the supply input. \$\endgroup\$ Commented Feb 10, 2023 at 9:54
  • \$\begingroup\$ @Newbie : Could you try connecting both Sense pins to the Source instead of 24V? Mixing figures 6-3 and 6-5 and see if it works. I don't understand \$\endgroup\$
    – GCarles
    Commented Feb 10, 2023 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.