0
\$\begingroup\$

I have a USB bus, on a main board I am trying to break out to wire in an arduino type device. I have Identified Ground. There doesn't appear to be a 5VDC line anywhere though. There are 6 pins, 3 of them show 3.3VDC. None however are 5VDC.

I think the BUS is usb, as a device on the same bus (different board) lists as a USB fingerprint scanner. I have tried using the 3.3 pins as vcc which seems to power the arduino just fine, but the port, will not enumerate. under any circumstance. (Ive tried swaping the wires around on D+/D- in every combination.)

Ive googled, but I don't see anything suggesting that USUB is 3.3V under any circumstance as VCC. is there a new standard? or why does nothing have 5VDC on it?

\$\endgroup\$
2
  • 2
    \$\begingroup\$ If you have a custom board with custom connectors, there is no mandate that 5V is on the connector. USB device would regulate 5V down to 3.3V anyway, so it might be just getting 3.3V from host directly. \$\endgroup\$
    – Justme
    Feb 14, 2023 at 0:18
  • 2
    \$\begingroup\$ I think more details and photos of the board are in order. \$\endgroup\$
    – Bryan
    Feb 14, 2023 at 1:18

1 Answer 1

2
\$\begingroup\$

While not conforming to USB standards, the 3.3V VBus setup is often used for internal connections in laptop-like devices (think keyboard or similar devices).

This avoids the otherwise required voltage reduction 5V->3.3V on the USB device side, but won't allow long cable connections.

You can use this with many 3.3V mircocontrollers directly - but I strongly recommend reading datasheets (and manuals) here. Some controllers require V_Bus to be above 4.5V as per USB spec - these cannot be used here.

\$\endgroup\$
1
  • \$\begingroup\$ very interesting thank you! \$\endgroup\$
    – j0h
    Feb 14, 2023 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.