I am trying to get serial data from my custom-built ESP32-Wroom-S3 board in the Arduino IDE

The PCB works. I can program it from the Arduino IDE and make the LEDs blink.

enter image description here

I have the simplest possible code, so I don't think that is the problem

void setup() {

void loop() {
  digitalWrite(1, HIGH);
  digitalWrite(1, LOW)

In the serial console of the Arduino IDE I only get:

Build:Mar 27 2021
Saved PC:0x4037d23e
mode:DIO, clock div:1
entry 0x403c98d8

THE Arduino IDE is the latest version (2.0.3). The ESP was installed via the Board Manager as recommended in the ESP docs (link).

I have configured the Arduino IDE as follow:

Board: ESP32 S3 DevModule | UsbMode: USB-OTG

Does S3Wroom integrated USB support send serial data via USB? If yes, do you have any tips on what could be wrong?

  • 1
    \$\begingroup\$ Do you have "USB CDC On Boot" enabled? \$\endgroup\$
    – StarCat
    Commented Feb 17, 2023 at 16:38
  • \$\begingroup\$ No. Is that needed? What is it? :) \$\endgroup\$ Commented Feb 17, 2023 at 16:51
  • 1
    \$\begingroup\$ Double check the baud rate of your serial console. IIRC the bootup baud rate of the ESP32 is 115200, but your program declares the serial bus at 9600. This could explain why you see the bootup messages but not your program outputs. \$\endgroup\$
    – InBedded16
    Commented Feb 17, 2023 at 17:39
  • 1
    \$\begingroup\$ USB CDC On Boot will enable the ESP32-S3 native USB as a serial device. It will enable serial output from the ESP32 to the host over its (native) USB. \$\endgroup\$
    – StarCat
    Commented Feb 17, 2023 at 20:22
  • \$\begingroup\$ I did both things, and now it works! I had to enable CDC and change the baudrate to 115200. Whoever creates an answer I will mark it. Thank you very muchh!!! \$\endgroup\$ Commented Feb 17, 2023 at 22:06

1 Answer 1


You need to select

Enable on the Menu Tools >> USB CDC On boot

upload the sketch to the ESP32 and it should be working.

Here's a good tutorial about it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.