I just had some custom Arduinos manufactured, and it's the first time I've included a USB controller, CH340. I'm able to flash the bootloader to the Atmega2560 over ICSP, so the AVR is fine. However when I connect the USB cable, there is no device showing up at all. Its not a driver issue, there is no sound and I doublechecked in usbdeview. Also tried other cables, so I'm suspecting I messed something up in the design since its the first time I'm including USB.

The exact chip used is this one, datasheet. I followed this example when wiring it up, except I have no crystal as the CH340C is supposed to have a built-in crystal.

Anything obvious standing out please?

enter image description here

enter image description here

  • 2
    \$\begingroup\$ Looks like the CH340 gets no power. Power is blocked by capacitor C14. This capacitor was probably meant for decoupling. But that's not how its connected. Try to shorten it for a first test. \$\endgroup\$
    – Codo
    Feb 22 at 15:16
  • \$\begingroup\$ I noticed i made a moronic mistake with the decoupling capacitor C14.. However even if i bypass it and verify 4.65V at the CH340, there is still no USB device showing up. \$\endgroup\$ Feb 22 at 15:16
  • \$\begingroup\$ @Codo Yeah i just noticed, however it still doesnt work even if i remove it and short the gap. \$\endgroup\$ Feb 22 at 15:24
  • 1
    \$\begingroup\$ The next problem with your circuit is the floating V3 pin. In your 5V setup, it is supposed to have a capacitor to ground. \$\endgroup\$
    – Codo
    Feb 22 at 15:29
  • 2
    \$\begingroup\$ @Codo That 3V3 capacitor was the last issue. Able to flash Blink via USB now. That will teach me to read datasheets properly and thoroghly. Pls post it as an answer and i will accept. Thank you for saving my sanity. \$\endgroup\$ Feb 22 at 16:00


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.