0
\$\begingroup\$

I rebuilt a camera battery (NP-F550) and need clarification as to what is going wrong. The battery charges and powers the camera without issue, but will only charge for ~5 minutes before charging stops. The camera runs for ~7 minutes on that charge. The cells are brand new, rated at 1800mAh, and are genuine. I was expecting them to take more than 5 minutes to reach their full capacity, so I'm assuming that the battery controller is cutting them off long before that happens. I did try charging for a couple hours, which produced the same result.

The cells that are being replaced are only rated at 1250mAh. I expected the new cells would only charge up to the old ceiling, but clearly it's capped much lower. Is it possible that there is some EEPROM on this controller that adjusted the charge ceiling while the old cells degraded? If that's the case, is there any way around that?

I gave my best shot at trying to identify the parts on the controller and only came up with a link for the IC labeled AV4X S8232B (EDIT: Link provided by user253751). I have no clue where to look past searching the labels, if that can even help. The controller is labeled ZN-L04A V200 on its back. ZN-L04A V200 controller

So what can be done to charge the cells more? What am I overlooking? I am most definitely not an electrical engineer, so apologies for my ignorance.

\$\endgroup\$
7
  • 1
    \$\begingroup\$ What voltage do the cells reach after charging stops? \$\endgroup\$
    – Polynomial
    Feb 22, 2023 at 22:29
  • \$\begingroup\$ I know that some chips will try to count the total coulombs going into and out of the battery. I don't know if that's what's happening here. Yes, it could also adjust the charge level depending on battery degradation if it is quite highly advanced. There are a lot more components on this circuit board than I'd expect on a simple, generic battery protection circuit. \$\endgroup\$ Feb 22, 2023 at 22:36
  • \$\begingroup\$ Here is the datasheet for the S2832 protection chip I can read the label of. It does not feature any kind of memory. \$\endgroup\$ Feb 22, 2023 at 22:38
  • \$\begingroup\$ @Polynomial This might be the root of the problem! The voltage on the first cell is just over 4V, where the second is at 3.5V. The joint connecting the battery tabs is actually quite big, and should be redone. I can only imagine that big joints can cause a wide range of different issues, especially if the joint connects the 2 batteries. \$\endgroup\$
    – zuzomuzabi
    Feb 23, 2023 at 8:46
  • \$\begingroup\$ @user253751 thank you for the link, I've added it to the post now, I really should have provided it in the first place. Also good to know there's no memory, it's looking like the issue is me rather than the hardware. And thank you both for the swift replies. I'll try and redo the solder job tomorrow and post my results. \$\endgroup\$
    – zuzomuzabi
    Feb 23, 2023 at 8:55

1 Answer 1

1
\$\begingroup\$

My problem was that the cells got unbalanced before I soldered them in.

All I needed to do was drain the first cell (done by attaching alligator clips to a device that required 4v), and then put the pack back into the charger. Has worked since.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.