2
\$\begingroup\$

About a week ago, I tried to use my Arduino Uno to program a a stand-alone ATmega328P with Optiboot. Not only was I unsuccessful, but now I can't upload sketches to the original ATmega chip. The "L" stays lit even when I press the reset button.

So I ordered an AVR ISP MKII to either unbrick my Arduino Uno or bypass the bootloader and upload a sketch. I followed the tutorials to use the ISP in Ubuntu 12.04 (Precise Pangolin), I have the programmer set to AVRISP MKII and I tried to "Upload sketch using programmer". This is the response:

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_program_enable(): bad AVRISPmkII connection status: Unknown status 0x00
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.
\$\endgroup\$
4
  • \$\begingroup\$ I've never used Arduino IDE to upload via ISP, but did you check the (serial) port selection? \$\endgroup\$ Commented Apr 18, 2013 at 4:54
  • \$\begingroup\$ 'The "L" stays lit' Where do you see that "L"? \$\endgroup\$
    – jippie
    Commented Apr 18, 2013 at 6:34
  • \$\begingroup\$ @jippie Maybe it is this? \$\endgroup\$ Commented Apr 18, 2013 at 6:41
  • \$\begingroup\$ Sorry, I meant the "L" LED on the Arduino Uno that is connected to pin 13. \$\endgroup\$ Commented Apr 18, 2013 at 19:08

1 Answer 1

2
\$\begingroup\$

If your Uno's AVR is the 28-pin DIP, the cheapest, quickest, most painless way to fix it is to replace the chip with another boot-loader installed one, available from lots of suppliers.

An FTDI cable (USB-A -> serial TTL) is so easy and convenient to use with your standalone, there's no need to risk your development board.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.