2
\$\begingroup\$

In Kicad 5, when one presses 'X', a track is not immediately created. Rather, one clicks in the workpiece to start the track.

I have recently upgraded to Kicad 7. Here, pressing 'X' on the keyboard starts a track immediately at the mouse location. This is undesirable.

Clicking on the "route tracks" toolbar button (to which 'X' is bound) has the behaviour I want. Oddly however, selecting "route single track" from the Route menu starts the track immediately.....from where the mouse was at the time of selecting the menu item. Seems a bit stupid.

I have looked in the hotkeys preferences; and googled; and come up empty. How can I go back to the previous behaviour? Short of pressing 'escape' all the time, I mean.

\$\endgroup\$
3
  • 4
    \$\begingroup\$ I think that's a good question, and the observation that starting a track from the cursor position when in the menu being useless actually justifies filing a bug report with Kicad. That community is Fast with a capital F, you might get that fixed, and the info how to do what you want (or a preference option to change to that behaviour or something) out of it as a sideproduct. \$\endgroup\$ Apr 16, 2023 at 14:12
  • \$\begingroup\$ @MarcusMüller I'm frankly amazed at the rapid progress in Kicad compared to commercial offerings. \$\endgroup\$ Apr 16, 2023 at 17:25
  • \$\begingroup\$ @SpehroPefhany right? The speed with with it overtook "pre-autodesk" Eagle was amazing. From zero to mostly equal or outcompeting Eagle is amazing. It's still a bit lacking on automation, layout-reuse, pre-production steps (panelling etc.), and simulation integration, but it's really not absurd to claim that at least for non-high-speed, normal-substrate projects, there's not that much reason to get an Altium license… \$\endgroup\$ Apr 16, 2023 at 17:30

1 Answer 1

2
\$\begingroup\$

You will want to select this option in your preferences

first hotkey selects tool

\$\endgroup\$
1
  • \$\begingroup\$ Yes! That fixed it. What an obscure option...! \$\endgroup\$ Apr 19, 2023 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.