1
\$\begingroup\$

I have an XBEE (XBee 2mW PCB Antenna - Series 2 (ZigBee Mesh)) and it only seems to work within 5 feet of the other Xbee. Is there a certain orientation or line of sight parameter for Xbee's? Is it possible something else could be causing interference?

\$\endgroup\$
4
\$\begingroup\$

So range is a function of a lot of stuff (see another answer about this topic here), but my wild guess here is one of two things. Either you aren't providing something to your circuit that you are meant to, or you have something in your area which is generating a lot of noise.

Most Zigbee devices operate in the 2.4GHz range, which these days is pretty saturated. Microwaves, wifi, X10 cameras (anyone still have these? mine stopped working once wifi became popular), etc. And on top of that, the proliferation of cheap non-FCC certified ebay electronics from China means that there are lots of things which are terrible throwing noise out into the spectrum. My friend had a fake Dell laptop supply he got off ebay which generated nearly 30V on ungrounded metal surfaces in a radius of about 5 feet!

So there are two good ways to check this:

  1. Go out to a park or something where there is less likely to be things generating lots of RF noise and see if you get more range
  2. Get an old AM radio and tune it to a station which is filled with static. See if it gets a lot louder or quieter when you unplug/plug in things around your apartment/home. If you find something which makes a dramatic difference, that may be the issue!

Second suggestion: if you have a circuit with a different Zigbee which works with a much greater range and a different Zigbee module, try swapping this one in and see if the range is better.

Third and final suggestion: turn down your bitrate. Slower transmission is general easier and less error-prone transmission. Don't think that Zigbee actually has a way to slow down the wireless chunk of the transmission process, but if it does it may help.

If all else fails: maybe you have a dud? Try returning it?

|improve this answer|||||
\$\endgroup\$
1
\$\begingroup\$

My problem was the coordinator chose channel 23, but the router first found it on channel 11 and stayed there. Setting the channel manually using SC=1000 fixed it.

"Digi Xbee starts on the first channel in the SC mask and stops on the first channel which grants it association. Depending on the age of the firmware on your Xbee ZB module it might start on channels 0x0B, 0x0C, or 0xD (11, 12, or 13)" source

|improve this answer|||||
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.