2
\$\begingroup\$

enter image description hereI have been trying to use a comparator with a sinusoidal input to turn an LED on and off but apparently I am doing something wrong.

I am using the LM393 IC with pin Vcc connected to 5V. I've tried it with a 9V battery. I have the non-inverting input connected to a sinusoidal input and the inverting input terminal grounded. Ground is of course connected to ground. I have simulated my exact design on Multisim. It works but I get no output in real life even though I have used multiple LM339s. The sinusoidal input is a 0.233 Vpp sine wave.

enter image description here

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Show us the schematic. A schematic tells us what you intend to do or think you did. A picture of your breadboard shows us what you actually did. The problem could be that you intended to do the wrong thing, or intended to do the correct thing but did not do what you think you did. \$\endgroup\$
    – DKNguyen
    May 3, 2023 at 20:03
  • 2
    \$\begingroup\$ LM393 has an open-collector output. It's been a while since I used Multisim but I seem to recall there was an erroneous model with op-amp style output instead of open collector? \$\endgroup\$ May 3, 2023 at 20:35

1 Answer 1

2
\$\begingroup\$

Look at this extract from the data sheet: -

enter image description here

So, one of your inputs is AC and that will inevitably take the input below 0 volts and, when that happens all bets are off. Because you might not be experienced, you might have tried a larger voltage and gone past the maximum limit of -0.3 volts.

Here's another recommendation you appear not to have implemented: -

enter image description here

You also need to have the LED and resistor as a pull-up: -

enter image description here

At the moment you appear to have the LED's resistor grounded.

I'm not ruling out other issues as yet unseen.

\$\endgroup\$
8
  • \$\begingroup\$ The maximum voltage applied is +- 0.116 volts with a 0.233 peak to peak sinusoidal voltage though. \$\endgroup\$ May 3, 2023 at 20:34
  • \$\begingroup\$ @MichaelBradley yes, I'm fully aware of that relationship. I'm also aware of the natural temptation to increase input signals when things don't appear to work. \$\endgroup\$
    – Andy aka
    May 3, 2023 at 20:50
  • \$\begingroup\$ Haha I understand. I didn't increase the voltage but I am going to read the data sheet and keep playing with it. Thanks for your input. \$\endgroup\$ May 3, 2023 at 20:59
  • \$\begingroup\$ Don't forget to connect the LED appropriately for the open collector output. as noted in this answer, and comments for your question. \$\endgroup\$
    – PStechPaul
    May 3, 2023 at 21:17
  • 1
    \$\begingroup\$ @Andyaka Some users react badly to terminology such as "Because you don't appear to know what you are doing ..." . We have received a flag (not from the OP) re this. In line with previous advice, it is strongly requested that you consider how what you write may be taken by others and frame statements in a way that are not likely to offend. We are well aware that such a "gentle" approach may seem OTT to some, but the aim is to use language which does not result in a constant series of flags and user complaints. Your anticipated cooperation is appreciated. Please edit your answer accordingly. \$\endgroup\$
    – Russell McMahon
    May 4, 2023 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.