I'm working with the Altium Designer version 20.2.4.

I'm using only 2 libraries. The first has only one component, a microcontroller from ST. The second is a library where another person put a lot of passive and active components, schematics and footprints with 3D models.

I've created 4 schematics and 1 PCB document to work on them. I've compiled the only schematic where I have put the micro and some passive components, and I can view them in the PCB document with no errors, but then when I try to add some new components, the same or other from the libraries (or from the miscellaneous internal library), the console throws errors with the nets and with the class of the recently added component. The errors are the following, when i.e. I try to put a new capacitor to the "MICRO" schematic:

Error list when updating PCB

I have watched a lot of official tutorials from Altium, and have read a lot of documentation, but I can't solve the problem. I think all the footprints are well associated with the schematic components, which is one of the "solutions" that the people talk on internet.

I'm really new using this program, so maybe the solution is more simple than I think now, but I'll be grateful if someone finds out.

MICRO schematic

Project view

If someone needs the project to make some tests, I can put in somewhere it's comfortable.

  • \$\begingroup\$ santiago deliotte - Hi, You posted an "answer" which seemed to say that you had solved the original problem, but now you had a new problem and asked for help with that. On Stack Exchange, you cannot ask new questions in something posted as an answer, so it was deleted. Also, you cannot extend a question by adding new questions to it (it becomes impossible to write a correct answer to a moving question). If the original problem has been solved, you can write your own answer below (and "áccept" the best answer to effectively close this question). Then consider asking a new question. Thanks \$\endgroup\$
    – SamGibson
    Jun 21 at 14:49
  • \$\begingroup\$ Also,, as you are new here, please read the tour & help center for the main site rules & etiquette, and to see how Stack Exchange differs from typical forums. Thanks. \$\endgroup\$
    – SamGibson
    Jun 21 at 14:52

1 Answer 1


From the error messages, it appears to me that capacitor C3's pins are not numbered "1" and "2". The program matches schematic pin numbers (not pin names) to the PCB footprint pin numbers.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.