1
\$\begingroup\$

I've designed a 4-layer board and when I run DRC I get this error claiming that the connecting between a via and the GND-plane is missing. Note that the bottom left via is the highlighted one that the error refers to.

Looking at the layout it seems quite obvious that the error is wrong since the next via and the component GND pads (which are obviously in the same zone on the top layer) do not trigger an error. There is also a solid ground plane underneath both these vias which extends throughout the board.
Furthermore, as you can see this is the only error I'm getting, but if I delete the troublesome via and run DRC again I get the same error, but for another via. And so it continues. Note also that there is no red DRC-error-arrow pointing at the via. Unclear why. Any ideas on what to look at to find the source of this? The zones are refilled. I am using KiCad 6.0.4.

As per request, here are also some menus and extras. And before someone suggests it, no I don't think it's the island option casing this, consider the 2nd layer solid ground plane!

I can't share too much of the design so I don't want to snippet the whole card etc.

Layout layer 2 GND plane GND fill settings

via menu

\$\endgroup\$
8
  • \$\begingroup\$ Have you refilled the zones? \$\endgroup\$ Jul 4, 2023 at 8:09
  • \$\begingroup\$ Yes. thank you though. You actually have proof of it in the screenshot since the check mark for DRC to refill them for me is ticked. \$\endgroup\$ Jul 4, 2023 at 8:39
  • \$\begingroup\$ Mostly out of curiosity, what items are under "Schematic Parity"? \$\endgroup\$ Jul 4, 2023 at 16:00
  • \$\begingroup\$ Could you show the window where the via is configured (select the via and hit e)? Also, could you show the whole board and layers (or, at least, a larger portion with some more connections visible)? \$\endgroup\$
    – awjlogan
    Jul 5, 2023 at 9:32
  • \$\begingroup\$ @spehroPefhany Under Schematic Parity are 3 fiducials that are only used for alignment. The schematic symbol has a pad that I've not Xed as not connected because it doesn't look nice on the sch. I'm almost certain they are not the cause of the strangeness here. \$\endgroup\$ Aug 16, 2023 at 12:45

1 Answer 1

1
\$\begingroup\$

I'm not sure it is completely related but I added a new component to the circuit. For some reason (I think spacing) the GND fill zone didn't connect or made thermals to the GND pad of that component. When I added a manual trace from the pad to the zone, this DRC error with the via disappeared. Perhaps some pad was not connected to the zone, but the error didn't point out the correct object.

\$\endgroup\$
1
  • \$\begingroup\$ This might be worth raising on the KiCad bug tracker. \$\endgroup\$
    – Hearth
    Dec 14, 2023 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.