1
\$\begingroup\$

I recently purchased a MikroElektronika 4-20mA T Click MCU Add On Board MIKROE-1296, which features a MCP4921 DAC and XTR116 current loop transmitter, to control a current between 4-20mA.

However, I can't seem to get it to control the current to less than about 4.4mA despite being rated by MikroElektronika to have the current down to 4mA. Following is the schematic of the board provided by MikroElektronika.

MikroElektronika 4-20mA board setup

Image adapted from: MikroElektronika MIKROE 4-20 mA T Click schematic

I have written a program (via SPI) to both loop through the voltage range of the MCP4921 (with values from 0-4095 and back down again), and set the voltage to a "static" 0V to test what the loop current is. But after I connect a 24V source on the screw terminals, run the script and measure the current through the loop, the current won't go lower than 4.4mA in either of the two cases.

I have confirmed that the voltage output of the MCP4921 uses the entire range from 0-4.095V (and back down again) when looping through its range, and 0V when setting the value to a constant low. And the voltage was measured by connecting Vout and GND_iso to a multimeter.

I have tried asking at a TI forum but they claim, to my understanding, that given the current circuit, it should even control a current range with its lowest value being 0mA. And that for it to start at a 4mA lower range a 102.4kOhm resistor should be connected between Iin and Vref on the XTR116. So I have no idea why it won't reach down to the lower current range, since the MikroElektronika board isn't equipped with the 102.4kOhm resistor in the first place.

Additionally, when looping through the DAC's voltage range, the transmitter has this weird behaviour where it slows down significantly when it gets to around 4.4mA and "speeds" up again after it has gotten to a slightly higher current.

Here's a link to the relevant forum https://e2e.ti.com/support/amplifiers-group/amplifiers/f/amplifiers-forum/1244601/xtr116-producing-a-4-20ma-current-loop-alongside-an-mcp4921-dac

Anyone have any experiences with this board that can tell me if I did anything fundamentally wrong or if there may perhaps be something wrong with the provided PCB or anything else?

If it helps I've programmed the SPI using an arduino uno.

Added information

For further clarification I have drawn how I connect the voltage source and current measurement for the MikroElektronika PCB. Which is as indicated in the figure above with "V" representing the 24V source and "A" how I measure the current.

Regarding the different voltages present existing on the board, either 3V3 or 5V is chosen to be the Vcc depending on the position of a jumper and this 3V3 or 5V is provided from the female connector from for instance a MCU.

Vcc_iso is the voltage provided by the voltage regulator on the XTR116 IC which is powered by the loop voltage on V+ to step down the voltage to about 5V. This can be seen in the figure for the typical application of the XTR116 in the figure below.

XTR116 typical application circuit

Image source: Texas Instruments - XTR116 datasheet

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Sounds very much like you've proven the board you have in hand can't be used in your application. You didn't design it so we can't help you in modifying it to correct its error (perhaps a poor design?) You could ask to return it either swapping it for another or getting back your money. It really does sound as though you tested the DAC output. Perhaps there is an oscillation (you said 'slow down' but that could be the cause) that the designers failed to account for. Perhaps there's a bad chip. But what are you actually asking for, here? I'm not quite sure. (We aren't a user's group.) \$\endgroup\$ Jul 10, 2023 at 11:35
  • \$\begingroup\$ How are you wiring up the current loop circuit and measuring the current? Where is the vcc-iso coming from? Best if you draw a schematic of your whole setup. There’s three power sources involved - 3V3, vcc-iso and your loop supply. How are they related and wired? \$\endgroup\$
    – Kartman
    Jul 10, 2023 at 13:30
  • \$\begingroup\$ Alexander Navasca Skinstad - Hi, To comply with the relevant site rule, a link back to each original source webpage / PDF etc. copied or adapted from elsewhere is required. I saw you mentioned the sources in the text, thanks for that, although actual links are needed. In order to help you, I found what I believe to the sources for those images and added them (please correct the links if I was wrong). For the future, please note it's your responsibility to add the links :) As you're new here, please see the tour & help center for the main site rules & etiquette. Thanks. \$\endgroup\$
    – SamGibson
    Jul 10, 2023 at 19:32

1 Answer 1

2
\$\begingroup\$

I had the same issue and investigated it to get to the root cause. After some research and finally, removing the isolator chip, I identified that the problem lies within the isolator chip, which was drawing ~4.2mA from the 5V regulator line alone, which wasn't as per the datasheet. Add the 0.2mA drawn by the DAC and now you can never go below ~4.4mA! I then ordered some ADUM1411ARWZ (version A, but really, it won't have a difference since the cause is different) isolators as a replacement and soldered those on. The 4-20 mA loop then worked correctly and I could even go to as low as 1.7mA (yay!).

I contacted Mikroe and they confirmed that they are aware of the problem and it is indeed the isolator chip ADUM1411BRWZ and that "one batch" of modules had a faulty batch of isolators (not every day that this happens!). They confirmed that the issue is now fixed and any new orders should be good, they even sent me 2 replacement boards. Unfortunately, one of those boards was still bad, although this allowed me to idetify the exact batch number of the faulty isolators:

  • BAD - ADUM1411BRWZ #2141* 4015657.1
  • GOOD - ADUM1411BRWZ #2241* 6008416.1

I told Mikroe about this and they said they will recheck all of their stock of these modules to ensure that the isolators have the correct batch number. Now, to fix your issue I suggest that you check the isolator chip batch number and then contact the supplier if the batch number is BAD. Explain to them that the board is faulty and that Mikroe knows about this and that they should return all of their modules that contain the isolator with the BAD batch number back to Mikroe as per their request. I hope that helped!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.