0
\$\begingroup\$

I have a very simple circuit as follows

schematic

simulate this circuit – Schematic created using CircuitLab

when the motor is connected in this fashion, the netduino activates the transistor, but nothing happens. If i swap the motor with an LED, the LED does light up, so that incidates that the motor isnt getting enough power...

So i connect the motor direct to power and gnd, and it spins. Does this mean that the transistor is drawing so much current that it is stopping the motor working?

\$\endgroup\$
  • 1
    \$\begingroup\$ The diode is backwards. As it is connected currently, when the transistor is on, the diode is a short-circuit. \$\endgroup\$ – Renan Apr 27 '13 at 17:23
  • \$\begingroup\$ Also, I don't see why the 100ohm resistor is there - it would be better if it were connected between netduino and base of the transistor. \$\endgroup\$ – pjc50 Apr 27 '13 at 17:29
  • \$\begingroup\$ Motor details? What is R1 supposed to be doing? \$\endgroup\$ – Leon Heller Apr 27 '13 at 17:29
  • \$\begingroup\$ Sorry, that's my fault in the schematic, it is the correct way round on the breadboard \$\endgroup\$ – Wayneio Apr 27 '13 at 17:30
  • \$\begingroup\$ Updated schematic. Removed unnessecary resistor, and even tried replacing the transistor with a darlinton pair, but in this case there was even less power, as a LED shows even less brightness in place of the motor. \$\endgroup\$ – Wayneio Apr 27 '13 at 17:48
5
\$\begingroup\$

I believe the netduino IO to be 3V3 and this means the emitter of the transistor can never be higher than about 2.7V with any load connected. This is realistically the problem you have - the motor is only receiving about half of the 5V it needs and is therefore stalling. The led works because it only needs a couple of volts (more than likely).

You need to have the motor and diode (same way round as drawing shows) from the collector up to +5V. The emitter needs grounding and the input to the base (from the netduino) goes via a 1k resistor.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Okay, that makes sense. I have swapped the motor and diode to the collector side of the transistor, but am still not seeing the motor move. Could it just be that the output from the netduino IO is not enough? \$\endgroup\$ – Wayneio Apr 27 '13 at 18:17
  • \$\begingroup\$ Have you used a 1kohm resistor in the base? As a quick test if you disconnect the resistor from the IO pin and link that point up to +5V does the motor turn? If yes, then maybe you haven't programmed the IO pin correctly. If no then try linking that point up to +3V3 - this should still turn the motor - if not then try lowering the 1kohm to 220 ohm - let me know Wayneio \$\endgroup\$ – Andy aka Apr 27 '13 at 18:24
  • \$\begingroup\$ Yeah, 1k. I added an LED in series, after the emitter to ensure the circuit was working. The transistor's base pin then was connected the the +5v, and the LED lit up(so bright nearly blew it) but the motor still did not turn. I tried the motor again to just 5v and gnd and it worked, so there must be a problem with either the transistor or netduino IO \$\endgroup\$ – Wayneio Apr 27 '13 at 18:35
  • \$\begingroup\$ You need to take out the LED because it will reduce the drive to the motor by 2V or maybe more. Try again without the LED Wayneio \$\endgroup\$ – Andy aka Apr 27 '13 at 18:42
  • \$\begingroup\$ I should have clarified, i just used the led to test the circuit, but did take it out again \$\endgroup\$ – Wayneio Apr 27 '13 at 19:22
2
\$\begingroup\$

Your high-side switch (transistor) is functioning as an emitter-follower, which (among other things) means that the emitter voltage can never be higher than 0.7 V less than the voltage coming out of the Netduino — or 1.4 V less in the case of the Darlington pair.

If the microprocessor on the Netduino is operating at 3.3V, this means that you're only delivering 2.6 V (or 1.9 V with the Darlington) to the motor.

A better configuration would be to put the transistor on the low side of the motor, or said a different way, put the motor between the 5V supply and the collector of the transistor.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.