0
\$\begingroup\$

I created the following PCB with KiCad 7.0, the dimensions are shown in the image below:

enter image description here

enter image description here

I tried to export the PCB with this configuration:

enter image description here

When I try to print, to etch the board using photoresist method, the printer's outcome is smaller than the board shown by the KiCad (images 1 and 2). The dimensions should be 36.08x50.67 mm, but the final outcome measurement is 22x29 mm.

Does anyone know what's happening?

I'm printing the svg generated by kicad via libreoffice. The image is imported and printed normally. I've checked the size of the image on libreoffice, and, apparently, kicad doesn't generate an svg file with the same size of the board:

enter image description here

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Most likely you are printing it incorrectly. We can't know how you are printing it, maybe add screenshots of printing the SVG export, instead of SVG export. \$\endgroup\$
    – Justme
    Commented Jul 25, 2023 at 23:21
  • \$\begingroup\$ More information regarding the printing process added, @Justme \$\endgroup\$
    – andre.hre
    Commented Jul 26, 2023 at 2:05

1 Answer 1

3
\$\begingroup\$

Print it to a PDF, and then print the PDF out. Make sure the scale for printing is set to 1:1.

In the print window, it should look like this:

enter image description here

Or like that:

enter image description here

Either of those options will do the right thing.

Once you succeed, you'll know what to tweak when printing from KiCad directly.

When printing directly, don't plot to SVG. Just go straight to Print. SVGs will be scaled by the browser to fit and they don't print right usually.

\$\endgroup\$
3
  • \$\begingroup\$ How do I get the negative version using print? \$\endgroup\$
    – andre.hre
    Commented Jul 26, 2023 at 2:06
  • \$\begingroup\$ It should work also by plotting to a pdf and then printing from the PDF viewer. \$\endgroup\$ Commented Jul 26, 2023 at 13:58
  • \$\begingroup\$ It worked! Thank you very much! \$\endgroup\$
    – andre.hre
    Commented Jul 26, 2023 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.