1
\$\begingroup\$

I try to share the exporting step file from Altium with our mechanical department (they've already used the NX Siemens CAD tool).

When exporting a 3D file from Altium and opening it into NX program, each component creates a 3D step file because of its footprint. Actually, we expect them to create a single body (for only PCB). Which export method can we use for that and how should we adjust the export method for this output?

I used the export feature of the step file in Altium more than one time. But once we open it in the MCAD program, It creates a separate body for each component. How do we fix that?

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ There is a "Export as Single Part" option visible in your screenshot. What does that do? \$\endgroup\$
    – nanash1
    Jul 31, 2023 at 13:39

1 Answer 1

1
\$\begingroup\$
  1. Start with Nanash1 said above
  2. Within the 3D simple body export options tab, click "prefer simple bodies"

simple bodies are just the extruded version of the detailed 3D body. So this is refereeing to the spherical, extruded or spherical options when placing 3D bodies within the properties panel.

Both companies I've been at prefer parasolids than step files, I think they may be a more optimized file, but that is a complete guess. Try exporting a parasolid while using simple bodies and a single part (if that last option is there use it - I don't remember off hand).

One of the above should work for you. If they don't (for some reason..) let me know and we can work through it.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.