I'm using version 20.2.4 of Altium Designer.

I have several libraries with hand-made component schematics. These components have a Designator, a Comment and a Description, but I only want to see the designator when I use them on a new schematic. Therefore, I toggle the hide option (symbol of an eye) in the library, because I don't want to do it every time I use the component. After that, something strange happens, and although I have selected the hide option in the library, it's unselected in the schematic sheet when I place the component.

enter image description here

It's really annoying, and I think it's a kind of a bug. If someone knows something about this, I'd be very grateful to read an answer.


1 Answer 1


You could take it up with Altium, but I never managed to disable it either. What I ended up doing is:

If I wanted a significant comment, I used fields. The best example is for resistors. I wanted their value with the tolerance. The description would then be "=value+"+/-"+tolerance+"%". That way, all the comments are significant on the schematic.

If I don't want a comment, I usually set the description to =" ". Since it's not a significant field anyway, I don't mind having it with a space in it.

If I want a comment but not to see it, what I did is on the symbol, I display the refdef and description (It's an option in the visual setting of the symbol) and set the font to something very small and the color of my component. Then I placed it somewhere no one would see and locked it. I also checked the box to not autoposition it.

You could also open a ticket with Altium for that issue. I kinda got used to it and now it doesn't really bother me anymore.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.