0
\$\begingroup\$

I am trying to do a copper pour on one of the layers on my PCB and for some reason, the nets are not visible to any other layer except the top layer.

I have tried to do a copper pour on the top layer and that worked perfectly.

Please help, I am new to Kicad and have been trying to find a solution for quite a while.

Thank You.

Top Layer with nets

Layer 2 with missing nets

I have tried to search for it online and some instructions suggested it was a visibility issue but since the instructions were quite old and I am using Kicad 7.0, I just couldn't follow them as the GUI has changed over the years.

When the ground copper pour is applied it only cover the header connections for the ground and ignores all the pads.

Copper Pour GND

\$\endgroup\$
2
  • 1
    \$\begingroup\$ whatr happens when you select the layer with the pour on the right-hand-side "Layers" list? So that there is the small triangle next to it. \$\endgroup\$ Commented Aug 20, 2023 at 16:15
  • \$\begingroup\$ @MarcusMüller The small triangle is indeed there and the GND layer is also applied. For some reason, it only applies to the pin header connections GND signals but it ignores all the pads. \$\endgroup\$ Commented Aug 20, 2023 at 21:54

3 Answers 3

0
\$\begingroup\$

for some reason, the nets are not visible to any other layer except the top layer.

Your first image shows surface mount components on the "front" (aka top) layer and, not surprisingly, their net names are clearly visible on the copper pads. This is because net names are only shown where copper exists hence, you see them when the top layer is activated because, that's the only layer that has copper present. And, as a consequence, you won't see net names on inner or bottom layers because: -

There is no copper on those layers that can receive a net name identifier.

If you want to prove this for yourself, place a via near one of the SM components and route a track to it from a component. Then switch the top/front layer off and the net name will appear on the via copper.

\$\endgroup\$
4
  • \$\begingroup\$ Hi, thanks for your help. The layers are definitely copper it says so in the physical stack-up. Even if I do a copper pour the nets still don't show up. \$\endgroup\$ Commented Aug 20, 2023 at 21:42
  • \$\begingroup\$ Read what I recommend you do. \$\endgroup\$
    – Andy aka
    Commented Aug 20, 2023 at 22:02
  • \$\begingroup\$ In your new picture, what layer did you flood copper onto? It looks like the bottom layer and, of course, it can't connect to pads on the top layer without via connections. \$\endgroup\$
    – Andy aka
    Commented Aug 21, 2023 at 8:08
  • \$\begingroup\$ Thanks, Andy. You are absolutely correct! \$\endgroup\$ Commented Aug 27, 2023 at 23:08
0
\$\begingroup\$

The net names are used (needed) only on copper layers to show electrical connectivivty. To see the them, select the "visibility eye" near a copper layer in the layers menu at the right.

enter image description here

To create a copper zone:

  1. Select the layer and make it visible.
  2. Select the Add Filled Zone at the right or under the Place menu.
  3. Click and release where you wnat the first vertex. This will open the Copper Zone Properties menu.
  4. Verify the layer selection. Notice the warning regarding net assignment.
  5. Select the desired Net from the list. If you want one of the auto-oenerated numbers, deselect the "Hide auto-generated net names" box to see them all.
  6. Fill in other zone properties like Name. The zone priority assists if overlapping zones. This is handy, get to know it.
  7. Select OK and draw the copper zone.

enter image description here

\$\endgroup\$
2
  • \$\begingroup\$ Hi, thanks for the help. This is the method I have been using to apply a GND copper layer. For some reason only the holes inside the SAMTEC headers get filled but the pads of the components are ignored. \$\endgroup\$ Commented Aug 20, 2023 at 21:50
  • \$\begingroup\$ The Samtec footprint may not be right.@BilalAfzal \$\endgroup\$
    – RussellH
    Commented Aug 20, 2023 at 21:55
0
\$\begingroup\$

Go to Preferences -> Preferences -> PCB Editor -> Display Options and check you have the highlighted Net Names -setting selected Net name display setting

After that you should see the net name on any tracks you route on any layer.

\$\endgroup\$
1
  • \$\begingroup\$ Hi, thank you for your help. The setting is enabled. \$\endgroup\$ Commented Aug 20, 2023 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.