2
\$\begingroup\$

I am using my Arduino Uno as a programmer to program my ATtiny85. I uploaded the ArduinoISP sketch to my Uno. I double checked my wiring, did some googling, but I still can't figure out why I get this error:

avrdude: stk500_getsync(): not in sync: resp=0xff

when I run this command:

sudo avrdude -p t85 -c avrisp -P /dev/ttyACM0 -b 9600 -U flash:w:src.hex

Any suggestions? Thanks!

\$\endgroup\$
  • \$\begingroup\$ start by changing avrisp to arduino. \$\endgroup\$ – jippie May 2 '13 at 6:52
  • \$\begingroup\$ @jippie I already tried that, nothing different happened... \$\endgroup\$ – user151324 May 2 '13 at 13:05
1
\$\begingroup\$

You have requested 9600 baud serial communication, which is probably not correct for your ISP sketch.

I believe by default that it is now 19200, but you can tell for sure by finding the initialization line in your ISP sketch, such as

void setup() {
  Serial.begin(19200);

The -b parameter to avrdude specifies the baud rate for communication with the programmer.

In contrast -B paramater specifies the speed of the actual programming, though I'm not entirely convinced that this is honored when using the ISP sketch.

\$\endgroup\$
2
\$\begingroup\$

By default, an Arduino Uno automatically resets itself whenever the host computer opens its serial port. After that, the boot loader waits for a few seconds to see whether there is any serial traffic intended for it, and that disrupts the communication sent by avrdude.

You’ll have to disable this auto-reset by connecting a 10µF capacitor between the RESET and GND pins (- going to GND, of course).

\$\endgroup\$
  • \$\begingroup\$ I already had that a 10µF capacitor between the RESET and GND pins, thanks though... \$\endgroup\$ – user151324 May 2 '13 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.