1
\$\begingroup\$

Whenever I want to burn the hex file on my chip, the following error message always appears:

Power On Failed

Cannot communicate with target chip

The programmer I am using is AVR USB programmer, from ABLab Solutions. The software I am using for program burn is extreme Burner AVR.

I don't think this is a problem with the driver because it says it has found an USBasp on USB port. There was an option to select the chip model, where I selected ATmega16 (because 16A) was not there. How can I solve my problem?

EDIT: The picture of the circuit: I used Zener for just-in-case voltage fluctuation.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • \$\begingroup\$ Is the chip powered during programming? \$\endgroup\$ – Matt Young May 6 '13 at 5:25
  • \$\begingroup\$ Not from external source. doesn't the usb powers the chip @MattYoung ? \$\endgroup\$ – cipher May 6 '13 at 5:28
  • \$\begingroup\$ Multimeter showd very low voltage though, do i have to supply external voltage? \$\endgroup\$ – cipher May 6 '13 at 5:33
  • \$\begingroup\$ Double check your connections. If its not the connections, then probably the ATMEGA 16 is locked and you should by a new one. There is a way to unlock, but it's really difficult. I advise you to buy a new one and it will work. \$\endgroup\$ – Injy Sarhan Nov 26 '13 at 22:04
3
\$\begingroup\$

AVR chips must be powered during programming. They are NOT powered from the programmer. I would recommend reading the following Application Notes

AVR910: In System Programming

AVR042: Hardware Design Considerations

\$\endgroup\$
  • \$\begingroup\$ Ok, so i powered it with 5.1V DC (100mA) supply, There's the same case. Same Error! \$\endgroup\$ – cipher May 6 '13 at 16:05
  • \$\begingroup\$ If that's the case, then there is probably something connected wrong. Please post a picture of your set up. \$\endgroup\$ – Matt Young May 6 '13 at 18:22
  • \$\begingroup\$ Edited the post. please see now \$\endgroup\$ – cipher May 6 '13 at 18:53
  • \$\begingroup\$ What about the rest of the pins? \$\endgroup\$ – Matt Young May 6 '13 at 23:02
  • \$\begingroup\$ All the shown pins (6) of the uC are connected to the programmer. I've checked it many times, The connection is correct. \$\endgroup\$ – cipher May 7 '13 at 1:48
1
\$\begingroup\$

I had same problem

1)connections were ok . 2)drivers were installed correctly.

but same error:power on failed

I tried second mcu (Atmega32): but problem not solved same error. I tried second usbasp : but same error.

Then finally i got it accidentally ,the problem was usbasp hardware......(i dont meant manufacturing fault) if you see it you will find jumper connection named(CLK) when i put the jumper on it ,it work succesfully. connect the two leads named (CLK) on usbasp.

\$\endgroup\$
0
\$\begingroup\$

Also had this problem. Was hardware issue. The clk pin of the atmega8 on the usbasp had no connection. A touch with the soldering iron and now it is working. Took me 2 days to find his little bug.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.