0
\$\begingroup\$

I'm observing a mysterious behavior that I cannot explain.

NOTE: Where I use the word "instantly" below I mean this occurs in less than the 1 ms scale I'm using on my digital scope. Also, I'm saying "5 V" to keep it simple, but it was between 4.5 - 5 V across the tests I did.

I have a board with a SPST-NO relay with a 12 VDC power coming in (ultimately coming from a car battery), and a fuse on one side of the NO contact. There is nothing else on this input circuit, just the positive terminal of the battery, through some connectors and traces to the fuse, then to the relay NO contact.

The coil is fed from the same fuse, but then through a diode and a 10 Ohm resistor

On the other side of the contact is the cathode of the blocking diode D1, with the anode connected to ground so it will be reverse biased when the relay is on. That then feeds an output pin on the board. Nothing else on the board is connected to this output circuit - just the relay output, the cathode of the diode, and the output pin.

  • Diodes D1 and D9 are both MCC GS1J Diodes
  • Flyback diode D30 is an OnSemi MURA110T3 Diode
  • Relay RL1 is an Omron G5LE-1A-DC12 relay

schematic

simulate this circuit – Schematic created using CircuitLab

Odd behavior #1: When I switch the relay from on to off (without the cap connected), instead of the voltage at the pin dropping to 0 instantly, it instantly drops to about 5 V, then ramps from 5V to 0V.

For my application, I need the output to stay above 6V for at least 20 ms after the switch is opened. I figure this should have a simple enough solution. If I put a suitably sized capacitor on the output of the relay, it should easily maintain the voltage above 6V for 20 ms. So, I connected a 3.3 mF electrolytic capacitor to the output and verified the polarity was right.

I left the relay on long enough to charge the cap to 12 V. I verified the charge by manually disconnecting it from the source (represented by SW2 in the schematic) and checking the voltage of the cap with a scope when not connected to anything else. The scope verified it was 12V with a very gradual self discharge, about what I would expect.

As a double check, I then repeated the test but connected a resistor across the capacitors terminals and the discharge roughly followed the RC time constant.

I then connected the cap to the output pin of the board. There was NO LOAD connected at all. I left the relay on long enough to charge to 12V.

Odd behavior #2: When the relay switched OFF, the voltage at the output once again instantly dropped to about 5V and then the cap slowly self discharged from 5V to 0V. (Also note, I ran the test multiple times and when I removed the cap from the circuit the cap was also at 5V... I don't know how it discharged so fast - the max reverse current of D1 is listed as 5 uA... so I don't even see a path to discharge )

I can't explain this. I thought that maybe the wrong diode was on the board. I might expect behavior like this with a Zener diode with a 5V breakdown voltage but I verified the manufacturer and P/N on the diode as MCC GS1J - and that is the correct diode, not a Zener diode. Additionally, the diode is not going into any kind of breakdown (Zener or otherwise) as it is rated for 600V reverse biased. I also had multiple boards and got the same result with every one so this wasn't a matter of a bad component. I looked at the spec sheet for the diode, and couldn't see any specs that would explain this kind of behavior... but maybe someone here can? Why would this diode (I'm assuming the diode because there's nothing else in the circuit) cause the voltage to drop instantly to 5V with or without a capacitor?

Update I edited the schematic above to add elements I missed, including a flyback diode across the relay and a diode that is between the fuse and the relay coil.

Further, I expanded on the circuit for the coil side of RL. There is a 10 Ohm Resistor, R77 on the +12V side, and switch SW1 is actually switching the coil to ground, not to +12V.

I also added resistances for the cables, where there are cables connecting to a chassis ground or to the board. This is to represent not just the cables, but also any resistances in the connections. After reading responses, I think a bad ground connection is the most likely cause. The overall system that this is a piece of is very complicated and has many ground paths and some look suspect. Note that the resistances shown are just placeholders, I have not yet measured the resistance but will, I had to put something in the schematic. Note that Diode D1 and the relay coil both connect to the ground plane of the PCB board. Also, for the test there is a wire from the cap both to the board output pin and to chassis ground. I also added resistances for the battery cables / connections.

\$\endgroup\$
9
  • \$\begingroup\$ Can you repeat the experiments but include a flyback diode from your ground to the positive input of your relay coil? I agree that your circuit doesn't have any clear reasons to be doing this but the fact that you don't have a path for the flyback current of the coil could potentially cause some of the behavior. I'm not convinced that's the problem though. Do you have a picture or the actual schematic of the board you're using? \$\endgroup\$
    – cEEa
    Oct 6, 2023 at 22:51
  • \$\begingroup\$ What is the voltage rating of the capacitor? \$\endgroup\$ Oct 6, 2023 at 23:26
  • 1
    \$\begingroup\$ Are you sure you actually got the GS1Js that you ordered? It's rare, but I have gotten parts where the wrong component was packaged in a bag that said it was the right component. Even reputable sources make mistakes. \$\endgroup\$
    – Hearth
    Oct 6, 2023 at 23:37
  • \$\begingroup\$ Also note that what you're seeing on the scope is probably not the capacitor's self-discharge--what you see on a scope will be dominated by the 10 MΩ impedance of a typical scope probe, unless the capacitor is particularly bad. Even if you're using a 100× probe with 100 MΩ input impedance, you'd probably get more leakage through that than through the capacitor dielectric. \$\endgroup\$
    – Hearth
    Oct 6, 2023 at 23:38
  • \$\begingroup\$ @cEEa I simplified the circuit to what I thought mattered - which is, I was focusing on the load side. There is a flyback diode in the circuit. Sorry I didn't reflect that in my schematic. I should also note that the ground points are not the same for the coil and load side of the relay. It may take me a bit to update the coil side as there's a few other nuances there, but I will update it when I can. \$\endgroup\$
    – Trashman
    Oct 9, 2023 at 15:22

1 Answer 1

1
\$\begingroup\$

A really bad ground wire, here R1 in the schematic, could explain the measurements.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
5
  • \$\begingroup\$ I would think RL1 (RL for a relay is a new one... You usually see K) might have trouble switching with that much series impedance, but if the bad connection is elsewhere, maybe. I'm not sure I believe this, though; it's hard to get a connection that bad without it being completely open circuit. \$\endgroup\$
    – Hearth
    Oct 7, 2023 at 0:51
  • \$\begingroup\$ @Hearth I agree, but the whole thing smells like a GND issue somehow. My model just produces all measurements presented by the OP, the instant drop at VM2 on open, the following slow decay, the remaining DC voltage in the cap. I have no better idea, that matches all these things. There may be a miswire in the return path not meeting BAT- but another load that finally is connected to BAT-. \$\endgroup\$
    – Jens
    Oct 7, 2023 at 1:02
  • \$\begingroup\$ Just to clarify, when I tested the cap and saw the slow decay also with the resistor across it, I completely isolated it from the rest of the circuit, so any potential circuit issues in the rest of the circuit would not be seen in those tests. I will take a look at the grounding, for sure. Thank you for the suggestions. \$\endgroup\$
    – Trashman
    Oct 9, 2023 at 15:18
  • \$\begingroup\$ @Jens Thank you very much for the suggestion, I think you're on to something. I added more detail to my question to account for possible areas of resistance, and a few other details I missed. I will be going back and checking all these points to see if there's a high resistance path. \$\endgroup\$
    – Trashman
    Oct 9, 2023 at 17:01
  • \$\begingroup\$ Unfortunately, a "bad ground" is not the cause. It made sense, but I checked every ground 3 times, all the way back to Battery negative terminal and got 0.1-0.2 Ohms for every connection. I'm at a total loss at this point, but I appreciate the help. \$\endgroup\$
    – Trashman
    Oct 9, 2023 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.