5
\$\begingroup\$

I'm having a lot of issues regarding interfacing an Arduino wifi shield with the Arduino Uno. My Arduino works fine when the shield is not attached to it but when I attach the shield, I'm unable to upload the code; I get:

avrdude: stk500_getsync(): not in sync: resp=0x00

I also tried to change my board and uploading the code on Arduino due, then it gives:

device not found on COM 8 as error

Otherwise the boards are perfectly fine, they are working usually they should. Also, I'm unable to reset the board when the shield is mounted on the board.

This is the shield I'm using which is the usual Arduino's official shield:

enter image description here

These are the things i have already tried but none is working :

  • powered up the arduino from external power supply (12 V, 1A)
  • removed the shield and programmed it (code loads on board ) but then mounting shield on board, the led on pin 13 cease to blink
  • without using the shield , arduino works as usual (like that Rx, Tx pins work and pin 13's LED and power led blinks /lit up) but with the shield stacked on board , nothing seems to work
\$\endgroup\$
  • \$\begingroup\$ Please add a URL to the datasheet/productsheet/circuit diagram of the shield to your question. \$\endgroup\$ – jippie May 7 '13 at 20:29
  • \$\begingroup\$ Have you tried jumping pins 7 and 3 as described in the comments on the product page? or checked to see if you need to jumper the IOREF pin as described on the getting started guide? \$\endgroup\$ – Craig May 8 '13 at 19:25
5
\$\begingroup\$

The error message you're getting "simply" means that the Arduino board isn't responding.

Regardless of the type of shield used, I've often seen this type of problems arise with power hungry shields, when the USB port is not able to provide enough current for both boards simultaneously (because of cheap cables, hub wich is not self-powered, ...).

A possible workaround (at least to test the validity of this answer) could be :

  • program the Arduino board without the shield attached
  • unplug the Arduino from USB
  • install the shield
  • plug from external power source with sufficient current rating
  • check that everything works.
\$\endgroup\$
  • \$\begingroup\$ Thanks for answering, i have done that , but nothing is working \$\endgroup\$ – user75736 May 7 '13 at 13:04
  • \$\begingroup\$ Sorry, but there's a lot of information missing here. What step isn't working ? What power source are you using ? And what does "nothing is working" exactly mean : how does the LED_ON behave ? Are the RX/TX and the PIN13 LEDs flashing at power up and how ? etc. You should complete your question with all these informations and all the steps you've performed (and which of them failed) for further answers to be usefull. \$\endgroup\$ – fred.grollier May 7 '13 at 14:44
  • \$\begingroup\$ OK i'll update my question \$\endgroup\$ – user75736 May 7 '13 at 16:03
2
\$\begingroup\$

Try:

  • just the 'blinky' sketch on the Uno (shield attached but do no I/O to it);
  • the Uno with another shield;
  • the shield with another Uno;
  • measuring the Uno's 5V rail with & without this or another shield;

My guess is the shield is shorting or otherwise overloading the Uno's power supply or some of its pins enough to suck down the supply voltage and prevent the Uno running properly, if at all.

\$\endgroup\$
  • 2
    \$\begingroup\$ Also check the voltage of the RESET pin to see if it being held low with the ethernet sheild on. That would stop the Arduino from running also. \$\endgroup\$ – BrianK May 7 '13 at 19:18
  • \$\begingroup\$ @BrianK - Good call. +1 \$\endgroup\$ – JRobert May 7 '13 at 19:38
2
\$\begingroup\$

That is almost certainly a programming USB comm issue. If you’re continually connecting and disconnecting the USB then the COM PORT might fail on the programming computer. Easily solved by closing the programming program and reopening it. If you get the “Wi-Fi Shield not found” error then you are most likely using an older Arduino than R3 i.e. R2 See here about making the link between the unmarked IOREF pin and the 3.3 Volt line. http://arduino.cc/en/Guide/ArduinoWiFiShield

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.