1
\$\begingroup\$

I am using a lithium ion battery to power a circuit board at 5V. I am using the LM2623 boost voltage regulator, which works fine when the battery is hooked up to the circuit board. I would like to add a soft latch switching circuit between the battery and the voltage regulator.

I have successfully replicated this soft latch circuit on a breadboard. I am able to use the soft latch switch with the battery as the input voltage to light up an LED. There are no issues whatsoever with latching. I am also able to use the soft latch switch with the 5V output from the voltage regulator as the latch's input voltage.

enter image description here

The P-MOSFET I am using is the IRF9510, which is rated up to 100V and 4A. The voltage regulator doesn't ever pull more than 2A to handle its switching circuit.

The N-MOSFET I'm using is the ZVNL110A.

Works:

battery --> latch switch --> LED

battery --> voltage regulator --> latch switch --> LED

Doesn't work:

battery --> latch switch --> voltage regulator

This non-working set-up has strange behavior at the output of the voltage regulator. Upon clicking the button in the switch circuit, the voltage out of the regulator will spike to about 1.3V and then slowly decay down to 0V. This decay takes at least a minute or two, which has me thinking that this issue has something to do with the fact that the load is capacitive and that is why the switch won't latch. I am wondering whether this is a result of the switching circuit within the voltage regulator circuit, or due to the input/output capacitors to the regulator circuit. For all I know, it could be malevolent fairies who don't want my circuit to latch.

I don't think the problem has to do with the P-MOSFET being unable to handle the current that the voltage regulator wants to pull from the battery, and I know it isn't the battery's discharge rate that is somehow limiting the current into the circuit. I also don't believe it is the N-MOSFET's current limitation in the switching circuit causing the problem, because I don't believe that component ever receives an excessive amount of current or voltage.

I am a relative n00b when it comes to electronics, so any help would be much appreciated. I can provide more info if needed.

---Edit---

I tried monitoring the voltage at the gate of the P-MOSFET to get to the bottom of this. When I have 3.7V coming into the latch circuit, the gate reads 3.65V. If the voltage regulator is not attached, clicking the button will bring the gate voltage down to 0 V. If the voltage regulator is attached, however, clicking and holding the button only brings the gate voltage to 3.32V.

\$\endgroup\$
  • \$\begingroup\$ The IRF9510 has a gate turn on voltage of between 2V and 4V - assuming your device is more towards the 4V region it may not turn on properly when you have the switcher as load - if in this state you short across the IRF does it begin working? \$\endgroup\$ – Andy aka May 7 '13 at 21:58
  • \$\begingroup\$ @Andyaka, I assume by shorting across the IRF9510 would be the same thing as eliminating the switch from the circuit. The circuit works fine when the battery is connected straight to the voltage regulator, without the latching switch in between. \$\endgroup\$ – Ryan Tuck May 8 '13 at 16:08
  • \$\begingroup\$ And... if you remove the link does the circuit take over and work correctly in that configuration? \$\endgroup\$ – Andy aka May 8 '13 at 16:46
  • \$\begingroup\$ Sorry, I'm not really sure what you mean. I have the battery-latch-VR circuit hooked up and it doesn't latch. If I short across the source and drain of the IRF9510, then yes, the voltage regulator works. Once I remove the short the circuit does not stay latched, and consequently the voltage regulator does not work (doesn't output any voltage). \$\endgroup\$ – Ryan Tuck May 8 '13 at 20:59
  • \$\begingroup\$ Yep that's answered the question i had. Try putting a 1n4148 diode across R3 with the cathode to cap C1 \$\endgroup\$ – Andy aka May 8 '13 at 21:22
1
\$\begingroup\$

I'm not an expert, but I think your problem is your weak 1M pullup R3. Until your soft latch switches on, the load circuit will be acting as a pull down through that 100k and it might keep the gate low.

\$\endgroup\$
0
\$\begingroup\$

If you have capacitor on output of this latching switch, it doesn't work. And DC/DC converter has capacitor on input. You must place 10k resistor as load first on output of this switch and then also put diode to + wire and then connect something what you want to control by this switch. Capacitor hold voltage up after switching action and R2 in this circuit then doesn't work like it should.

\$\endgroup\$
0
\$\begingroup\$

I had the exact same problem. I tried different soft latch circuits, but it didn't work. I then changed the size if the capacitor on the input side of the voltage regulator, to a larger size, and it worked. It seems like the voltage regulator become unstable when the transistor of mosfet of the soft latch switches.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.