2
\$\begingroup\$

enter image description here

I adjusted the clearance values, and that did not fill in the gap.

enter image description here

\$\endgroup\$
1

4 Answers 4

2
\$\begingroup\$

As other comments have said, this is not a clearance issue but rather a function of the thermal reliefs that EAGLE applies to polygon pours. Using the info tool, click on the polygon outline, and uncheck the box that says Thermals in the Polygon Section. Make sure you understand the pros and cons of using thermal reliefs though, there are times when they are not needed and times when they can save you a lot of hassle.

\$\endgroup\$
1
\$\begingroup\$

The other answers correctly identify this as being to do with thermal relief settings. You can either disable Thermals setting in the properties for that small polygon.

Alternatively you can modify the Thermal isolation setting in the DRC to reduce the gaps, though this may not be possible depending on you fabs capabilities, and affects the whole board.


On a related note, there is another issue with that polygon. Note the clearance errors around the bottom of the polygon:

Error highlighted between two polygons

This is because both the small polygon and the one below it have the same rank setting.

The rank of the polygon specifies the order in which the polygons are filled. Those with a higher rank number are filled later and will therefore pull back from polygons with a lower number.

When two polygons with equal rank number overlap each other, they will not correctly respect the minimum clearances and hence you get the DRC error. To fix this, you should change them to have different rank numbers in the polygon properties (you could also manually adjust the edges of the polygon for more clearance, but rank is sufficient).

\$\endgroup\$
4
  • \$\begingroup\$ Or reduce the minimum wire-wire clearance from 6mil to 2mil? Otherwise, I do not know how to go about ranking different stepper motor coil power polygons: imgur.com/a/R9onMMq \$\endgroup\$
    – adamaero
    Oct 19, 2023 at 16:10
  • 1
    \$\begingroup\$ 2mil won't be manufacturable (2mil = 50 micrometers!). On that design you can alternate the ranks for each of those polygons, first 1, then 2, then 1 etc. This will ensure that the clearances are respected between all of them. \$\endgroup\$ Oct 19, 2023 at 16:17
  • \$\begingroup\$ So put the top and bottom GND layers as rank 3 then? \$\endgroup\$
    – adamaero
    Oct 19, 2023 at 16:20
  • 1
    \$\begingroup\$ @adamaero that should work. I normally use 6 (highest value) for the main GND planes just so that I don't have to think about them when assigning ranks. \$\endgroup\$ Oct 19, 2023 at 16:22
0
\$\begingroup\$

This gap is part of the thermal reliefs you've applied to the pad or the zone. I don't use Eagle, so I can't tell you how to change it, but it's likely a setting either in the pad, the zone, or the footprint settings--just turn off the thermal reliefs for that pad if you need a solid connection.

\$\endgroup\$
0
\$\begingroup\$

As I remember using Eagle - placing a small "GND" via makes this gap refilled. I did it many times. Try different isolation value to fill this gap nicely.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.