1
\$\begingroup\$

I'm trying to design a circuit in GEDA/Gschem in Ubuntu. I could insert new components in the circuit but I cannot in the name change or add values. For instance when opening the window for attributes of a resistor, I cannot see 'value' on the list. I tried to add 'value' but the field for adding the actual numeric value is not a textfield and cannot enter anything. When I click on Add, I always get this message:

The input attribute "netname=" is invalid Please correct in order to continue

The name and value must be non-empty. The name cannot end with a space. The value cannot start with a space.

Utterly confusing. Any ideas what am I doing wrong?

\$\endgroup\$
3
\$\begingroup\$

It sounds like you are not managing to select anything other than the default attribute name. Click the dropdown arrow for the "Name" field where it defaults to 'netname' and select 'value' from the list. Then enter your value in the large "value" text area. Then select the visible button and choose name and value or not as you need for this attribute (value is normally visible and "Show Value Only"). Then click Add and it should put the new element in the list for you. If it doesn't look anything like the following image (also from Ubuntu) then your installation likely is broken in some manner.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ The thing is when I select name or value, the textfield is missing. I mean, there's no textfield in. There's nowhere to type to. \$\endgroup\$ – alkopop79 May 8 '13 at 22:03
  • 1
    \$\begingroup\$ Is your dialog titled "Single attribute editor"? If you double click you may be launching that which doesn't have the Value textfield. If so, instead select the component then enter 'ee' or choose Edit->Edit from the menu. That should raise the component attributes editor which looks like the image I included. \$\endgroup\$ – patthoyts May 8 '13 at 22:12
2
\$\begingroup\$

It's embarrassing but I found the solution. Right click, add attribute... what I referred earlier was just the preview of attributes. Either way, I solved. Thank you for your kind help! – alkopop79 just now edit

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.