2
\$\begingroup\$

I posted this on retrocomputing but they told me it would be better for me to post it here.

I was trying to make a Z80 computer. I tried with Intel 8088 and failed because I am inexperienced, so I thought Z80 will be easier to use. I bought a 4-pin 4 MHz crystal from eBay and I tried to check the crystal by connecting it like this:

Schematic

I am pretty sure the fourth pin is unused as there isn't a change in behavior whether I connect it to ground or VCC.

It produced these unusable clock signals that were always high and never went low.

  • on 1X: Vmax:2.65-2.75 Vmin:1.65-1.95

  • on 10X (50V): Vmax:26.50V Vmin:20.50

I powered the crystal with a 5V Arduino mega and measured the crystal with a FNIRSI-DSO 152 Oscilloscope which apparently when connected to nothing, will show Vmin:0.35V Vmax:0.20 which doesn't make sense so the oscilloscope might not be entirely accurate.

I tried connecting the crystal to a Z80A, but it didn't work.

I suspect this is the component and I think I bought the MCO-1510A so there shouldn't be an enable pin. Also the eBay listing says it is a crystal oscillator but I am not sure if it includes all the parts to a full complete oscillator circuit

https://www.opel.ece.vt.edu/reference/DataSheets/MCO-1510A-szgreat.pdf

Here is a link to a recording of what I am talking about: the recording

Update: I bought a new crystal oscillator from Farnell, but it still doesn't seem to produce 5V waves when viewed with my questionable oscilloscope. See also its datasheet.

\$\endgroup\$
6
  • 2
    \$\begingroup\$ Are you sure you have the 'A' part with pin 1 NC? (You could tie pin 1 somewhere useful to verify rather than assume.) They are supposed to drive at least one TTL load so a good quality scope probe and scope should be able to see something. (Can't speak to your made-in-China scope -- if it is one of those $20 ones then...) \$\endgroup\$ Oct 27, 2023 at 22:13
  • 3
    \$\begingroup\$ Why would you expect a quality product given the information provided in the link. Buy from a reputable supplier who sells named good who produce stuff to a recognized quality system and, provide a pdf data sheet. \$\endgroup\$
    – Andy aka
    Oct 27, 2023 at 22:51
  • 4
    \$\begingroup\$ I think your problems are caused by 'ebay" and "unbranded". \$\endgroup\$
    – Audioguru
    Oct 27, 2023 at 23:44
  • 1
    \$\begingroup\$ You'll save yourself a lot of frustration if you buy parts from reputable distributors. \$\endgroup\$
    – brhans
    Oct 28, 2023 at 13:29
  • 1
    \$\begingroup\$ Buying random parts from eBay is experts who like to live dangerously. Novices should only buy from known reputable sources, until they gather enough experience (takes years) to be able to "sniff out" legit sellers vs. fraudsters. \$\endgroup\$ Nov 14, 2023 at 20:46

1 Answer 1

8
\$\begingroup\$

The oscilliscope you linked to has a 200 KHz bandwith - it will not show anything near the correct waveform and voltages of a 4 MHz signal.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ The bandwidth is damning enough... and then the sampling rate is only 2.5M \$\endgroup\$
    – Ben Voigt
    Nov 14, 2023 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.