0
\$\begingroup\$

The setup:

I plugged an STEVAL-MKI224V1 board (basic eval board for baro sensor) on a nucleo F411RE. Communication happens through i2c bus.

I added 4.7k pull-up resistors on SCL and SDA.

The wiring:

  • SDO to VDD (set i2c address)
  • CS to VDD to activate i2s communication
  • VDDIO to VDD to nucleo 3.3V
  • GND to nucleo GND.
  • SDA and SCL to nucleo.

No internal pull ups are used.

The issue:

As communication was not successfull on first frames, I plugged a scope on SCL and here's what I get:

enter image description here

On the first bytes, the low level is not +/- 0V as it should be.

Other tests:

  • I tried a 10k pull-up, the result is the same.

  • I tried with only pull-ups (without eval board), result is ok.

  • I tried with another eval board for another sensor (Rohm), the result is far better but there's still a "rounded" 0. On this view, I zoomed a bit, code and i2c configuration is the same:

enter image description here

What did I miss?

Pictures of the setup:

enter image description here enter image description here enter image description here

\$\endgroup\$
4
  • 1
    \$\begingroup\$ The text doesn't mention it, but is GND connected between the boards? Consider editing the question to include a schematic of the connections between the boards. \$\endgroup\$ Nov 13, 2023 at 15:32
  • \$\begingroup\$ Yes, it is. I did my best to improve the question but sorry, I don't have schematic. \$\endgroup\$
    – Julien
    Nov 13, 2023 at 15:59
  • \$\begingroup\$ Looking at the picture of the connections I can't see anything obviously wrong. \$\endgroup\$ Nov 13, 2023 at 16:21
  • \$\begingroup\$ You were not that far: I changed GND naughty dupont cable and it works. Thanks! – \$\endgroup\$
    – Julien
    Nov 13, 2023 at 17:01

2 Answers 2

2
\$\begingroup\$

Looks like

  • either you've got some precharged capacitive load on your SCL,
  • or your SCL carries the involuntary job of exchanging current until ground potentials between two parts of your system have equalized.

Barring the possibility that you added a literal capacitor from SCL to ground or Vcc, I find the latter more plausible. Make sure you're not just connecting SCL and SDA between parts of your system – but also GND.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ I changed GND naughty dupont cable and it works. Thanks! \$\endgroup\$
    – Julien
    Nov 13, 2023 at 16:59
2
\$\begingroup\$

The black ground wire is loose and makes no contact.

That will explain the waveforms and the pin looks loose on the socket.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.