3
\$\begingroup\$

I am trying to build a circuit to regulate temperature for a few microheaters. Here's the circuit I am using:

enter image description here

This is a constant temperature controller circuit often found in the research papers and online articles. When the bridge is balanced \$\frac{R1}{R2} =\frac{R_{pot}}{R_H}\$ By changing \$ R_{pot} \$, we can change the the operating resistance (temperature) of the microheater \$R_H \$.

If there is a disturbance (cooling, wind ), the microheater Temperature will decrease, thus unbalancing the bridge. However, the Op-amp feedback will regulate the current that goes to the Wheatstone bridge and brings the bridge back to balance, thus keeping the microheater temperature constant.

Now, the problem is, if I connect a single microheater to any of the four op-amp, it works as expected. However, if I try to connect four microheaters to the four op-amps, not all of them work. Why do they work individually but not when run at the same time?

Also, If I apply a small voltage (~1.5V) pulse to the op-amp output pin, the circuit starts working again. It’s as if I have to apply a small voltage to boot the circuit.

What could be a possible reason for this, and how can I avoid it?

I am trying to understand if it's something to do with this particular op-amp, or something more fundamental.

\$\endgroup\$
1

1 Answer 1

4
\$\begingroup\$

This is a fundamental issue.

You need to prevent the output from going so close to ground that the difference between the inputs becomes less than the offset voltage of the op-amp, if it's driving the output in the wrong direction (low). The polarity of the offset voltage can be either positive or negative, in principle it may be random between op-amps.

If the offset voltage is in the favorable direction it will always start. If the offset voltage is close to zero it may start with noise or it may start at some ambient temperatures (as seen by the op-amp die) and not at others.

Here's a circuit that adds 10mV or so offset (assumption is that the bridge resistor values are relatively low compared to 10kΩ).

It's possible you could replace the circuit in the box with just a single resistor but you'd have to calculate the effects using the real values and ranges of your bridge components.

schematic

simulate this circuit – Schematic created using CircuitLab

An even simpler method is to just parallel the transistor E-C with a resistor. That will set a minimum power level for the bridge, and you would need to figure out a value that meets both requirements.

\$\endgroup\$
2
  • \$\begingroup\$ Thank you. Would you have any advice on how could I make it less sensitive to the offset voltage variation? \$\endgroup\$
    – TK23
    Nov 29, 2023 at 0:17
  • 1
    \$\begingroup\$ You can add some offset to the output or to the input. I mentioned the output, I'll put a schematic showing the input above. \$\endgroup\$ Nov 29, 2023 at 1:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.