0
\$\begingroup\$

I'm trying to power a small microcontroller board using the USB-C of a smartphone, to do so I took a USB C - USB A that has 4 lines (Vcc, GND and 2 data), but I'm not able to get 5V out of it.

Simply testing the power line gets less then 1V and drops to 0V if a load is applied, I also tried putting data lines in pull-down with no results.

I don't need high power, so I'm fine with a simple solution (I can't implement any software protocol on data lines) to get few Watts.

Edit: I also tried with a USB-C phone charger with similar results.

\$\endgroup\$
7
  • \$\begingroup\$ Important details are missing. Is the adapter with a Type-A plug or receptacle? And the other end of the adapter has Type-C plug to a smartphone? Also not needing high power and then needing few watts is mutually exclusive. If you have a Type-A device, it must not draw more than 0.5W without negotiating. \$\endgroup\$
    – Justme
    Nov 29, 2023 at 12:47
  • \$\begingroup\$ Yes, I'd like to connect the usb-c to the smartphone (and use it as power source), on the other side (eventually cutting the cable and soldering directly the power line) I'll connect the device (to act as sink) \$\endgroup\$
    – Paa
    Nov 29, 2023 at 12:54
  • \$\begingroup\$ Afaik not every Phone can actively drive it's USB-port. Some newer Phones do support USB-PD, though. What model is your Phone? \$\endgroup\$
    – S_G
    Nov 29, 2023 at 12:57
  • \$\begingroup\$ I's a Samsung phone, but I had similar problems using a Samsung phone charger (with usb-c output) \$\endgroup\$
    – Paa
    Nov 29, 2023 at 13:03
  • \$\begingroup\$ You have to ask for power with the USB OTG protocol. \$\endgroup\$
    – Jeroen3
    Nov 29, 2023 at 13:10

1 Answer 1

2
\$\begingroup\$

In order to get 5v out of USB-C — with no data negotiation — you have to pull the cc1 and cc2 leads low, through 5.1k resistors iirc. I just did a PCB like this, and it worked.

\$\endgroup\$
1
  • 2
    \$\begingroup\$ This is correct, but you don't have access to CC lines if you chop an Type-C to Type-A adapter half in the middle. The resistors are already embedded in the Type-C plug, assuming it was a correct type adapter with a Type-A receptacle, and if the adapter had a Type-A plug, it is a wrong type of adapter anyway with wrong resistors. So this does not really answer the asked question. \$\endgroup\$
    – Justme
    Nov 29, 2023 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.