1
\$\begingroup\$

When this whole "smart soldering iron" craze was just getting started, I jumped on the bandwagon and got myself the very first revision TS100. What I also got then is the complete inability to comprehend circuits and build them correctly, or so I thought... until I switched back to using my Lukey soldering station, and everything I built was working from the get-go.

I did not mind this much, thinking I was just making some mistakes. Though the pattern started to creep up: anything I serviced on the go with the TS100 plugged into an SMPS would behave erratically or stop working. Among those are:

  • A Logitech trackball I tried replacing a button in: after soldering in the new button, the status indicator lights up orange (the only normal colors are green and red, so it's mixing them) and it's not detected by the receiver.
  • An Arduino Pro Micro: tried to hook it up to something and after soldering the terminals it just stopped appearing on the computer, even in dmesg or lsusb.
  • A NEC pager of some sort: tried to solder in a serial connector, and I made sure to connect the TS100's grounding lug to the negative battery terminal. First try it worked, but then a wire came loose, and I soldered it back in while forgetting to connect the iron's ground to the pager... Sure enough, after that the pager would no longer turn on.

At that point, I was convinced the TS100 is either not ESD-safe, or that's the "half mains on an SMPS ground line" thing being the issue, and just went paranoid about watching out for the ground connection, until I got a Pinecil and the problem vanished.

Of course, that NEC pager also kicked around for a few months on my desk, but even occasionally putting in a battery in the hopes that it will miraculously work didn't help — it was dead as a dud.

Until today, around 1.5 years since then.

I wanted to check something about that pager, and I put a battery in without much hopes. But somehow it turned on just fine, all the EEPROM settings were intact, and it was able to even receive a message! (from a fake modem soldered instead of the normal RF baseband)

So, puzzled, I take the Arduino, which was for some reason still not in the trash bin, even after being killed by the TS100 around 5 years ago. Plugged it in... And it works!

Thus, as of writing this question, I also dug up the trackball, killed just a few weeks after the pager... At first it didn't work, but running the pairing software on the laptop got it detected and now it works!

I have a feeling it might be that the current of the ESD/half-mains-thing/whatever was not enough to burn the bonding wires but enough to polarize the silicon of some chip for a while to cause erratic behavior. But this is just speculation, and honestly I'm completely lost as to why this happens. What gives?

\$\endgroup\$
4
  • 1
    \$\begingroup\$ This is why ESD damage is so nasty: you can get latent or intermittent problems, the circuit can work for a long time and then suddenly fail out of the blue. If something that was previously broken due to ESD damage is now working again, don't count on that being the case in the long run. For example imagine that a bonding wire is broken indeed: shaking the physical IC a bit will then result in a pretty random outcome: it may work fine, it might not work at all, there might be a short and a puff of smoke. All depending on how that broken wire ended up - you are essentially throwing dice. \$\endgroup\$
    – Lundin
    Dec 20, 2023 at 14:52
  • 1
    \$\begingroup\$ It looks like other components from the circuit connected to the devices were damaged, not the devices themselves. If by any chance you still have these circuits on your bench pile, you could check. It's unlikely that three very different devices fail and then recover miraculously. \$\endgroup\$
    – Fredled
    Dec 20, 2023 at 15:11
  • \$\begingroup\$ @Fredled yep, I still have all of them. For the trackball it's definitely the chip because the button traces go into the controller IC directly, and the software was bugging out — if it was a passive like a pullup resistor, I'd assume it would work, but behave erratically in regards of sensing the offending button's state. \$\endgroup\$
    – akasaka
    Dec 21, 2023 at 2:43
  • \$\begingroup\$ @Lundin they are not going into anything mission critical (how critical could a POCSAG pager be in 2023 anyway...), but if it was a loose connection I think it would behave more erratically than just a "fail for a while, suddenly heal itself later". I'm really puzzled at what is the failure mode here. \$\endgroup\$
    – akasaka
    Dec 21, 2023 at 2:44

1 Answer 1

2
\$\begingroup\$

Its likely that the failure mode is not what you thought it was. ESD or thermal failures look like this:

enter image description here
https://www.analog.com/en/technical-articles/maxim-leads-the-way-in-esd-protection.html

So if you "overvolted" or "overcurrented" a device, it's highly unlikely that the damage got repaired on its own as traces get vaporized or shorted to each other.

\$\endgroup\$
1
  • \$\begingroup\$ Yes, that's why I was wondering what is the failure mode I'm encountering here. The thing you've shown was my expectation basically, but apparently it's something different. \$\endgroup\$
    – akasaka
    Dec 21, 2023 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.