0
\$\begingroup\$

I'm encountering an issue in Altium Designer that is proving to be quite challenging. After importing some libraries into my PCB projects and updating the PCB, I noticed that the "Rules" section under the Design tab has disappeared. I've tried opening new projects and even deleting the recently added libraries, but to no avail.

Currently, all I see is the Constraint Manager, and the absence of the Rules section is causing complications in my workflow. I'm seeking assistance on how to revert this or bring back the Rules section.

Any guidance or suggestions on how to resolve this issue would be greatly appreciated. Thank you in advance for your help!

Altium Version: 23.11.1

\$\endgroup\$
2
  • \$\begingroup\$ Please list your version number, also restart altium \$\endgroup\$
    – Voltage Spike
    Commented Jan 10 at 22:53
  • \$\begingroup\$ Thank you for your answer. I have restarted but nothing has changed. Also, my Altium version is 23.11.1. \$\endgroup\$
    – Gre Search
    Commented Jan 10 at 23:53

2 Answers 2

2
\$\begingroup\$

Constraint manager is a new feature in Altium and it is intended to replace the Rules in the future. When old projects are opened in Altium, the intended behavior is that Rules are used. When new projects are created in Altium, the intended behavior is that Constraint Manager is used.

Doesn't quite work correctly.

This is from memory, so might be a bit off...

Go into your Altium settings. At the bottom right, there's an "Advanced" button. Click it. Search for "constraint" and disable the two constraint manager options there and restart Altium. This will force Altium to use the legacy rules.

\$\endgroup\$
1
  • \$\begingroup\$ Hello, Thank you for your help. I deleted Altium and made a clean install it worked. But when I started the second project it was the same. Now, I did what you said and it worked. Thank you. \$\endgroup\$
    – Gre Search
    Commented Feb 22 at 9:01
0
\$\begingroup\$

Your installation is most likely corrupted, the best bet is to save your user profile and reinstall. Before you reimport your user profile, check to see if the menu is there. If it dissapears after you reimport the user profile, then its probably the user profile and you'll have to start over again.

Another thing you could try is to reset the toolbar/menu system or reset the user profile to default.

Another thing that would be interesting is to push D then R and see if the rules pop up in the mean time.

\$\endgroup\$
2
  • \$\begingroup\$ Thank you again for your response. I tried the first step you mentioned, and it solved the problem. So, I couldn't try the other options, but eventually, it worked. Thank you again. \$\endgroup\$
    – Gre Search
    Commented Jan 11 at 0:50
  • \$\begingroup\$ If you like the answer use the voting system and mark the answer \$\endgroup\$
    – Voltage Spike
    Commented Jan 11 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.