1
\$\begingroup\$

I'm trying to figure out how to wire up an LED, probably controlled by a FET, for an activity indicator for ethernet. I'm not trying to make one that supports official error codes or anything, but just something that blinks on and off as the line goes high or low.

So what is the voltage differential applied to the lines, and would they be high enough to power an LED or control a FET spliced into the line?

EDIT:The point of this indicator is actually not to verify transmission or proper TCP/IP activity, but instead just to make sure that there is anything happening on the line.

\$\endgroup\$

1 Answer 1

5
\$\begingroup\$

This isn't practical. Since modern Ethernet has a code, there are transitions even when there are no packets. The LEDs you see on networking equipment are driven by the PHY, not straight off the cable.

Even given that, the transitions are way too fast to see it go off an on with tranisions. The light would be apparently always on, and not blinking.

If you wish to wire up a signal, the fast Ethernet (100BASE-TX) voltages are +1 V, 0 V, and -1 V. I believe it is ~100 ohms. 1 V/100 ohms = 10 mA. If your LED is in parallel, you need it to not effect this too much.

\$\endgroup\$
5
  • 1
    \$\begingroup\$ That's understandable. The point of this indicator, though, is actually not to verify transmission or proper TCP/IP activity, but instead just to make sure that there is anything happening on the line. \$\endgroup\$ May 20, 2013 at 16:31
  • 1
    \$\begingroup\$ Phy = Physical Layer (en.wikipedia.org/wiki/Physical_layer) ie the electronics in a device. You could always use a scope... \$\endgroup\$
    – Spoon
    May 20, 2013 at 16:34
  • 1
    \$\begingroup\$ The goal is to make a device that can be easily fabbed with basic components (i.e. no PCB, no programming, etc.) that performs basic tests on multiple functions of a certain system. Most of the functions we're trying to test, we thought ahead and put a line out indicating if it is operating on a hardware level or not. We need a similar test for ethernet. I just basically want to light up an LED saying that the line is communicating in some form. \$\endgroup\$ May 20, 2013 at 16:42
  • 2
    \$\begingroup\$ That could be done with an opamp I think...buffered and using a peak detector maybe will give you an indicator light showing activity. It could be a bit fast for my usual LM324's from my bucket. Out of my depth at that speed. \$\endgroup\$
    – Spoon
    May 20, 2013 at 18:13
  • 1
    \$\begingroup\$ I just tried finding an amp capable of 1Mb to 100Mb (or 1Gb) per second at TI.Com ti.com/ww/en/analog/webench/amplifiers.shtml. I could not find anything that would not load the ethernet signal down and would indicate activity. If your just sensing "There is a signal" then it may still work. You could just hook up to an ethernet port transformer and measure there. The ethernet controller might not like the non-standard load tho. \$\endgroup\$
    – Spoon
    May 21, 2013 at 12:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.