0
\$\begingroup\$

I designed a circuit that has four relays on it. The input power source is 14.4V 2.2Ah lead acid battery. I am using an MC33063 to step down the input voltage to 5V. The relay driver circuitry is triggered by a GPIO pin of microcontroller that is powered with 3.3V (I am using an LM1117 to step down 5V to 3.3V to power the microcontroller.) Three relays are triggered by the same GPIO pin of the microcontroller. The remaining one is triggered from another GPIO pin of the microcontroller. I am using 2N7002 (SOT23-3 footprint) to drive relays and I have flyback diodes across the relay coils.

Under no load, the circuit/relays work as expected. When I try to switch four 220V AC bulbs using sometimes one or two of the relays stick in the ON state although I turn them off (using Trigger1 and trigger2 logic 0.)

I tried to change 2N7002 with new ones, but same thing happened. I replaced 2N7002 with BS170 (TO92 footprint.) I think it solved the problem (the relay does not get stuck.)

I would like to know why the relays get stuck when using the 2N7002. I have attached the schematic.

enter image description here

\$\endgroup\$
6
  • \$\begingroup\$ did you confirm that the gate was being driven to 0V when the relay was stuck on? \$\endgroup\$
    – Aaron
    Jan 30 at 18:53
  • \$\begingroup\$ Did you measure the voltage across the relay coil when the relay was stuck? It's not clear from the question that the 2N7002's were damaged or not, they can fail in closed condition with Vds being shorted. Did the relays then come back to life when the board was powered off? \$\endgroup\$
    – Voltage Spike
    Jan 30 at 19:35
  • \$\begingroup\$ We can't see from the schematics why they get stuck on. Either your MCU is driving them on or the relay contacts are unsuitable for mains and they weld together or the arcing and sparking of the relay contacts hangs the MCU with electromagnetic interference. Can you post the rest of the schematics and code to rule them out? \$\endgroup\$
    – Justme
    Jan 30 at 19:43
  • \$\begingroup\$ @Aaron Actually I did not measure gate voltage when relay stuck because GPIO pin was connected to another relay and it worked as expected. \$\endgroup\$
    – shdr
    Jan 30 at 20:20
  • \$\begingroup\$ @VoltageSpike I did not measure relay coil voltage, when stuck happened. I just changed 2N7002 just to see if it is related to this mosfet or not. The stuck condition happened not very often. Same Mosfet was working after some time. \$\endgroup\$
    – shdr
    Jan 30 at 20:32

1 Answer 1

1
\$\begingroup\$

I know you think it's related to the 2N7002s but the fact it only happened when there were loads strongly suggests it was contacts sticking, perhaps due to some surge characteristics of the load.

However the 2N7002 is not really rated to work reliably with 3.3v drive. The lowest voltage it is specified at is 5V, and even there it may have a relatively high Rds(on). It would be better to use a part such as AO3400A which has a maximum on resistance of 0.048Ω even with 2.5V drive. The 2N7002 having insufficient drive voltage is unlikely to have an effect directly on the relays but it's possible it could cause the relay to stay pulled in if the transistors got very hot. However the load or lack of load would be irrelevant in that case.

\$\endgroup\$
7
  • 2
    \$\begingroup\$ Weak pull-in may contribute to contacts welding/sticking. \$\endgroup\$ Jan 30 at 20:25
  • \$\begingroup\$ @evildemonic True, that's possible. \$\endgroup\$ Jan 30 at 20:55
  • \$\begingroup\$ @SpehroPefhany I measured Vds voltage of 2N7002s when relays were ON. Vds was around 0.3V. As you suggested I will change 2N7002s that can be driven using 3.3V logic and will check if relay stuck happens. \$\endgroup\$
    – shdr
    Jan 31 at 14:37
  • \$\begingroup\$ @shdr You should do that anyway, but my money is on the relay contacts sticking due to the load characteristics, sorry. \$\endgroup\$ Jan 31 at 14:40
  • \$\begingroup\$ @SpehroPefhany is there any method to prevent relay contact sticking? \$\endgroup\$
    – shdr
    Jan 31 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.