0
\$\begingroup\$

This is the first time I use Vivado. I can't set test_mySWLED.v as Top I can't set test_mySWLED.v as Top I Run Behavioral Simulation I Run Behavioral Simulation End up with mySWLED waveform instead of test_mySWLED waveform. End up with mySWLED waveform instead of test_mySWLED waveform.
Here is my project: https://hcmuteduvn-my.sharepoint.com/:f:/g/personal/nam_doanlqd_hcmut_edu_vn/ErPP0hArvftKhwEkHAG_6OQBoEStL0Emg8TZacZCJl6IuQ?e=tcYuo2
Thank you.

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

The reason you are unable to set the test_mySWLED.v module as top is because vivado is showing that it has some sort of syntax error.

Run the command check_syntax in vivado tcl console and it will describe the error.

It seems like you have not defined timescale properly.

timescale is defined as timescale <time unit>/<time precision> . You are missing the precision part. It should be like this timescale 1ns/1ps.

\$\endgroup\$
3
  • \$\begingroup\$ Oh, I have changed 1ns to 1ns/1ps. It's fixed bro. \$\endgroup\$ Feb 4 at 14:45
  • \$\begingroup\$ Hmm ... I tried to change 1ns/1ps to 1ns again, It's still work, I don't know what's going on ... but ... yeah ... somehow it fixed and I can see the correct waveform. \$\endgroup\$ Feb 4 at 14:49
  • 1
    \$\begingroup\$ Glad that this is resolved. about changing it back, May be you did not save the changes or may be you need to close and relaunch the simulation to make it work. \$\endgroup\$
    – Im Groot
    Feb 4 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.