2
\$\begingroup\$

I'm trying to follow Ben Eaters clock module design using the NE555 timer in astable configuration - basically right now to only flash an LED. I think the design is basically what is shown also in the datasheet.

I'm fairly confident that I've copied the circuit exactly from the design but my 555 behaves erraticly and slows down over time. I have already tried to replace the 555 timer, but the result is the same. I've tried a 5V USB power bank, a 5V phone charger and also my 5V bench power supply - same results.

  1. After connecting the power supply, the LED blinks as expected with a fixed on/off time
  2. After 2-3 minutes, the LED blinking starts to be erratic, sometimes taking longer, sometimes faster
  3. After another 2-3 minutes, the LED blinking stops completely or blinks only occasionally - the LED is always on.

This is my adapted schematic from the Ben Eater circuit - compared to the original it has R2 100k instead of a potentiometer and adds 340 ohm current limiting R3 in series with an LED:

Schematic

By now I'm fairly certain that it must have something to do with the 1uF capacitor. If I take it out and replace it with a new one, the LED blinks again as expected. I've now tried it with three capacitors and they all eventually lead to the same erratic behavior. If I leave the circuit unplugged for a couple of minutes, it recovers and works again as expected.

The 1uF capacitors are fairly old - I bought a box of different capacitors ~10 years ago. They are all unused and were stored at normal room temperatures. I know that electrolytic capacitors can dry out, but is that really an explanation for my observation? If that is so, shouldn't I expect basically all modern electronic devices to stop working after ~10 years? I've measured the capacitor with my multimeter and it shows 980nF, which is within the expected tolerance.

I have access to an oscilloscope, but I don't really know what I should look for. Measuring at the 555 output, I see that it reflects what the LED shows and measuring at the 1uF capacitor, I see that it doesn't discharge anymore when it is in the stuck state.

\$\endgroup\$
8
  • 1
    \$\begingroup\$ And where do you get your 555s? \$\endgroup\$ Commented Feb 13 at 14:56
  • 8
    \$\begingroup\$ Are you sure you have the capacitor polarity correct? \$\endgroup\$
    – John Doty
    Commented Feb 13 at 15:02
  • 1
    \$\begingroup\$ Have you got bypass capacitors at the chip supply? You can't expect any chip to work stably without supply bypassing. \$\endgroup\$
    – Justme
    Commented Feb 13 at 15:07
  • 2
    \$\begingroup\$ @JohnDoty - I first thought - no way, it wouldn't work at all if the capacitor was in the wrong way - turns out it does and turns out it produces exactly the issue I had. After fixing the polarity of the capacitor - I think it works as it should! \$\endgroup\$
    – schneida
    Commented Feb 13 at 18:42
  • 2
    \$\begingroup\$ Yep that's what happens. It's more exciting with the hermetic ones we used to use in aerospace: they explode after awhile ツ \$\endgroup\$
    – John Doty
    Commented Feb 13 at 19:25

1 Answer 1

4
\$\begingroup\$

This is typical of a polarized capacitor connected with the wrong polarity. It works initially, but fails after some time.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.