2
\$\begingroup\$

I made a custom single board computer based on the Allwinner V3s. This system on chip has an integrated PHY.

All components seems to work except I noticed that when I plug the ethernet cable to a switch, the power is cut off at the PMIC level. The LEDs I have for 3.3V, 1.8V and other systems are off, and there's no signal on serial.

Out of the several boards I made, one could still keep the system running when plugged, but the current consumption was about 1.1 amperes while it is usually below 100mA. The PMIC was burning hot. For the other boards the PMIC seems to put itself in security mode and no heat.

This behavior does not happen at all when I plug to my router, no over-consumption, no failure, the OS starts and I get an IP with DHCP.

This is the schematic for the RJ45 connector and the integrated PHY input:

schematic

I did not add the magnetics as all the reference designs I have seen with that SoC didn't have one.

Some info:

  • I tried with 2 gigabit switch, same brand, I will try another if I can find one.
  • The router is also gigabit ethernet.
  • Board and switch are plugged on the same wall plug.
  • Connecting two boards together causes no issue.
  • I tried several cables, same result.
  • On the schematic, the original RJ45 port has integrated LEDs and a metal shield, I changed it for a plastic one without LEDs.

I don't understand why a router connection would be perfectly fine and a switch not.

Edit: Most designs have the HR911105A connector which I found has integrated magnetics, maybe this is the issue here.

Edit 2 : I installed a RJ45 port with magnetics and all is working fine now ! thanks a lot

\$\endgroup\$
2
  • 5
    \$\begingroup\$ You absolutely need magnetics! I can't say for sure that this is the cause of this problem but I bet it is. As you noted, the reference design must use integrated magnetics. There is no way an Ethernet design would omit them. \$\endgroup\$
    – DoxyLover
    Commented Feb 28 at 5:19
  • 1
    \$\begingroup\$ You mentioned you used a different connector than the one on your schematic, which part number did you use, and how did you connect it? The part on your schematic is a HR911105A, which exposes 2 of the 4 pairs and has some internal circuity \$\endgroup\$
    – Ferrybig
    Commented Feb 28 at 9:14

1 Answer 1

4
\$\begingroup\$

The error is that there are no magnetics and your device passes 3.3V supply through the cable and other device.

Plugging it to another device will short 3.3V to GND through the cable, depending on how the other device terminates the wiring.

Some devices leave unused pins floating so nothing happens, but as those wires are used for gigabit ethernet, there is a risk of damage to the device, as the DC current will flow through the signal transformers.

So, an Ethernet design always needs the transformers, either as a separate discrete module, or integrated into the connector.

\$\endgroup\$
1
  • \$\begingroup\$ That was my first design with ethernet, I will know this for future ones. Thanks a lot ! \$\endgroup\$
    – Varech
    Commented Feb 29 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.