1
\$\begingroup\$

I am using Xbee Pro S1 modules with Rhydzo labz XBee Explorer Regulated with 3v3 to 5V Converter and XBEE Explorer USB in order to connect them to Microcontroller(Atmega 16)and laptop.To configure them i am using XCTU, but when ever i tried to test the modules, everytime a error comes(I am unable to upload screenshots) but that is similar to this question asked earlier.I didnt get any help from this.I also followed this link but even though it didn't make any changes.

I tried to do it manually.In XCTU in Modem Configuration>Modem type i select XBP24 and then i give the PAN ID(Pan id need to be same in both TX/RX) and then i gave Destination address high and low.Then i checked "Always update firmware checkbox" and then clicked write,it start doing something in my module, the TX LED of my module start blinking a message start coming on XCTU "getting modem parameter" and then Found bootloader active reprogramming firmware and the after some time, a message flashes on the XCTU "Getting modem type....Programming modem...Lost communication with modem Found bootloader active reprogramming firmware. Write Parameters...Failed", i cant get what i am doing wrong.I even followed a DIGI document to how to load XCTU bootloader with the help of terminal window on XCTU, Check DTR, Uncheck CST, check Break, then reset module, then uncheck break and write B on terminal of XCTU and it must return a Bootloader menu, but it never happen.

I am not able to get what should i do, i am totally stucked up.

\$\endgroup\$
  • \$\begingroup\$ If you get stuck on this try removing the resistor that goes to the RSSI LED, although I'm not sure if it applies to S1 module but no harm trying unless you especially want the RSSI LED working. I have to head off soon but if that works drop me a reply and I can post an answer with why it happens tomorrow. \$\endgroup\$ – PeterJ Feb 27 '14 at 11:55
1
\$\begingroup\$

Try to reflash the firmware using below steps

  • Change the baud rate to 38400 and check "No baud change" under PC Settings in X-CTU
  • Go to Modem Configuration tab, select correct Modem, Function set and Version
  • Click "Show Defaults"
  • Check "Always Update Firmware"
  • Click "Write" If "Action Required" window pop up, press the reset button on the interface board once, Digi interface provides reset button. I'm not sure about other boards. The pop up disappears and module gets programmed to selected firmware.
  • If you get any errors, like checksum error failed, you need to optimize your interface boards, refer the following link, http://www.digi.com/support/kbase/kbaseresultdetl?id=3418
  • Now go to PC Settings and change the baud rate to 9600 and uncheck "No Baud Change"
  • Go to modem configuration tab and select Read, you can see all the XBee parameters.
\$\endgroup\$
0
\$\begingroup\$

Make sure there are no other modules transmitting in the area. Set the host baud rate at 9600, which is default for a new module or fresh firmware update. This setting is under the PC settings tab, baud.

The most reliable way to determine if the module is communicating is to do it with AT commands as described in the manual on page 28. Open the terminal tab and type in +++ return. (0x2b, 0x2b, 0x2b, 0x0d) The module should respond with a "OK".

Also, Its not real clear what you have done, but it typically works better to "read" the module first, as xctu automatically detects the correct model and firmware.

Use Ctrl printscreen to capture the complete screen, then post exact errors if you still can't get it going.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.