1
\$\begingroup\$

TL;DR : The output voltage from my 5V DC to 3.3V DC stepdown seems to output 4.5V DC - why?

Background: I'm trying to power an Airport Express from USB rather than a wall outlet. I have discovered that the PSU inside the APE outputs 3.3V DC which powers the device. I figured I could rip the PSU out and replace it with a little board that steps the DC from 5 to 3.3, allowing my to use USB to power the APE.

So far I have cut the end off the USB cable and tested the red/black wires with my multimeter and can confirm it is outputting 5V DC. I then connected the red wire (5V) from the USB cable onto the VIN pin of the step down, and then tried testing the output voltage from the VIN by connecting the black lead of the multimeter to the ground wire (out of the USB lead), and the red lead of the multimeter to the OUT pin of the step down, its currently reporting 4.5V.

The step down device is one of these: http://www.ebay.com.au/itm/281058278731?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Am I testing the output voltage incorrectly or is my step down faulty?

Where should I be placing the black lead of the multimeter to close the circuit in order to test the voltage correctly?

I can provide pictures if anything needs clarification.

Thanks!

\$\endgroup\$
  • \$\begingroup\$ Ah, I think I have it working now. I needed to ground both the USB cable & the GND from the step down! \$\endgroup\$ – Ben Novakovic Jun 2 '13 at 0:28
  • \$\begingroup\$ Ben, you should submit your solution as an answer. You can also accept your own answer. This will prevent the system from thinking your problem hasn't been solved and repeatedly bringing the question back to the top of the active list. \$\endgroup\$ – The Photon Jun 2 '13 at 13:05
  • \$\begingroup\$ @BenNovakovic, hi just in the process of replacing a PSU in A1264 myself. So I wonder if your solution of using USB is still working — original PSU stated as 1.8A@3.3V which is quite higher than normal 0.5A over typical USB socket. And secondly can you share which wire is which since all of them are black and I can't pick it with PSU fried. Thanks \$\endgroup\$ – iskra Dec 30 '14 at 19:34
1
\$\begingroup\$

I found the datasheet for the device used on your board here.

First, this is not a buck regulator like the E-Bay seller is advertising it as. It is a low-dropout linear regulator. Luckily, for the input-output combination you're using, that probably does not cause too big a loss of efficiency. Your efficiency will be about 66%, where an actual buck regulator could get 80-90% at the expense of more components on the board (higher cost).

Second, be aware of one other issue that could cause the behavior you saw. This regulator has a minimum load current of 10 mA. If your load (plus the LED onboard the part you bought) draw less than 10 mA, the output voltage could also drift up above the normal operating point.

\$\endgroup\$
  • \$\begingroup\$ Great, thanks for this answer! That makes a lot of sense. \$\endgroup\$ – Ben Novakovic Jun 11 '13 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.