4
\$\begingroup\$

I picked up a couple of cheap Pro Micro's off eBay a while back. Both are blue, and have no brand identifier on them (ie, Adafruit, Sparkfun, etc.). The ebay ad. directly copies the text from SparkFun's Pro Micro - 5V/16MHz product page, where I got the schematic.

My challenge here is that I couldn't seem to get them to be identified by the IDE, so I'm trying to figure out just which they are. I know they are Pro Micro, but still not sure about the 3.3V vs. 5V part.

Here's a summary of what I know...

  • The product description says 5V
  • The boards are marked "V11"
  • The voltage regulator on the board is a mic5219 labeled LG50 (which is 5v)
  • The spot on the back where one can mark "5V" or "3.3V" on the circuit is not marked
  • The schematic states for the jumper "Closed for 5V version"
  • The J1 jumper is NOT bridged, which would imply it's configured for 3.3V (?)
  • The main chip is an ATMEL MEGA32U4.

So there's the quandry. 5V regulator, but J1 not bridged as for 3.3V? 3.3V?

Here are some photos... The two boards Closeup of un-bridged J1 and voltage regulator (LG50, a 5V one) Back of board showing unmarked 3.3V/5V and V11

Any suggestions on how I can precisely identify the boards or at least know if they in fact are 5V but should have J1 bridged? It seems based on the voltage regulator that it's 5V, but then J1 should be bridged if this was the case.

\$\endgroup\$
  • \$\begingroup\$ The photos make it hard to tell. And what you attached is the Official Pro Micro's schematic, not the clone you bought. Easiest thing to do is break out a multimeter, and check for continuity between the USB VCC pin and the board's VCC. Or follow the traces to confirm. \$\endgroup\$ – Passerby Jun 3 '13 at 7:04
  • \$\begingroup\$ Does it say "ATmega..." on the big black chip? What is the exact part number on the dots? \$\endgroup\$ – jippie Jun 3 '13 at 7:05
  • \$\begingroup\$ ATMEL MEGA32U4 on the main chip. RE: traces. So if USB VCC goes straight in, and it's 5V then the board would be 5V, correct? \$\endgroup\$ – Tim Holt Jun 3 '13 at 7:35
  • \$\begingroup\$ Also will mention that the ebay ad directly copies the text from SparkFun's Pro Micro - 5V/16MHz product page, where I got the schematic. \$\endgroup\$ – Tim Holt Jun 3 '13 at 7:41
  • 2
    \$\begingroup\$ @TimHolt - It's still better to edit the question. Also, cropping your pictures before adding them to your question would have made it easier to follow. See my suggested edit. \$\endgroup\$ – Mark Booth Jun 4 '13 at 8:22
4
\$\begingroup\$

At a glance, the operating frequency of the XTAL on board may tell the operating voltage of your Arduino.

If the XTAL is 16MHz, the device is probably 5V. If the XTAL is 8MHz, the device is probably 3.3V.

Make sure to use a multimeter and trace the power pins to the jumper / LDO. Also measure voltage at LDO output to see if LDO is active or not.

\$\endgroup\$
  • \$\begingroup\$ Yup - it looks like 16MHz on the crystal (to my old eyes). Chances are its a 5v especially since the voltage reg is also 5v. \$\endgroup\$ – Ron J. Aug 12 '13 at 12:03
  • \$\begingroup\$ Note that even though I know it's 5V, I still can't get the IDE to recognize it. \$\endgroup\$ – Tim Holt May 7 '14 at 20:15
  • \$\begingroup\$ @TimHolt does the LED blink when you power on the board? if not, maybe you need to re-flash the arduino bootloader. \$\endgroup\$ – Chetan Bhargava Jul 17 '14 at 18:53
3
\$\begingroup\$

Alright so based on the previous answers, it's not a matter of selecting the right board in the IDE.

I think I recall that the Pro Minis have a bootloader which does not keep listening when executing code. That means if you don't upload your code shortly after having reset your Arduino, it'll switch to the code in memory and you won't be able to upload anything.

Solution: hit upload, and just as you see "uploading..." after the compilation step, reset the board. The uploader tries a couple of times to communicate with the bootloader before giving up, so you should have a couple of seconds.

It worked every time with me in the past, and I had the same problems.

P.S: As a reminder, the bootloader is the program that (grossly said) is run right when the atmega boots, enables programmers to upload code in memory, and directs the CPU to that area to make it run.

\$\endgroup\$
2
\$\begingroup\$

In MIC5219 datasheet is information that LG50 is code for 5V regulator MIC5219-5.0BM5. 3.3V version have code LG33.

\$\endgroup\$
  • \$\begingroup\$ Note that even though I know it's 5V, I still can't get the IDE to recognize it. \$\endgroup\$ – Tim Holt May 7 '14 at 20:16
1
\$\begingroup\$

I've been having the same problem When powering via USB the board is not recognized so I had to use external power applied to VCC & GND, J1 jumper was not soldered. After checking the schematic, I realized that J1 must be soldered for the USB power to be connected to the board. It is now OK after soldering J1 pads together

\$\endgroup\$
0
\$\begingroup\$

see schematic:

  • Input voltage >16V - The J1 jumper is NOT bridged (input RAW);
  • Input voltage =5V - The J1 jumper is bridged (input VCC)
\$\endgroup\$
-1
\$\begingroup\$

OK Tim, Arduino does not recognize your board. Have you tried to double reset it before programming? It has an special bootloader that tries to avoid delays when in use. To be able to program it, you need to double reset it fast, then load the sketch in less than 8 secs. LEt me know if it works. It worked on mine :D

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.