1
\$\begingroup\$

I am simulating an RC integrator using an ideal opamp. I model the opamp as two different models (one with vcvs and the other with vccs) as shown in the below two cases. When I ran the ac simulation, only the one with vcvs worked fine. I don't understand why the vccs one didn't work. Could you please help me out?

Opamp with VCVS:

enter image description here

Opamp with VCCS:

enter image description here

AC Analysis Result: enter image description here

\$\endgroup\$

1 Answer 1

0
\$\begingroup\$

Simply put, when you use a VCCS model, you are assuming a transconductance amplifier (like a 5T-OTA) which inherently has a large (ideally infinity) output resistance. Under such conditions, the current through C is forced by the ideal current source, driving the input difference and the output current to zero. In other words, you have built a very lossy integrator! Generally, lower output impedances are preferred for continuous-time integrators using OpAmps, whereas a large output impedance can be used to design a discrete-time (switched-capacitor) integrator using a transconductance amplifier.

\$\endgroup\$
1
  • \$\begingroup\$ Thank you very much for your reply. I found out that there was a connection error in the circuit. After I fixed it, the two matched up. \$\endgroup\$
    – Kenlucius
    Commented yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.