0
\$\begingroup\$

I have two Xbee S6 wifi modules (XB24-WFSIT-001 rev G), DF robot xbee atapter V2 and sparkfun XBee Explorer USB.

I'm able to upload firmware to any of them (version 102D for example) using sparkfun adapter,(not df robot's one), but X-CTU can't set AT parameters after upload. I use this adapter with other xbees and it works fine.

Also it's not possible to enter command mode using +++ sequence, module just ignores it.

I have tried Xbee Factory -Hardware reset without serial communication and it didn't help.

\$\endgroup\$
1
\$\begingroup\$

I've "bricked" a series 1 and was able to recover it by a combination of the following. YMMV since you have a different version, but worth a try.

Obvious setting - the port speed. Stick with 9600 till everything works.

If your original firmware is much (much) older than the latest release - try to flash a less newer release from X-CTU first. Then, step up to the latest firmware.

If the XBee is not responding to AT commands. Change your PC (assuming Windows) port settings to use HARDWARE FLOW CONTROL (control panel, device manager, ports, COMx). Unplug and replug the XBee USB explorer. Start X-CTU. Don't try to test the port, just go into MODEM CONFIG tab, leave the firmware option UNCHECKED at first, click the RESTORE button. This should recover the XBee to a factory default. Then step up to an interim (less newer) firmware release and check the ALWAYS UPDATE FIRMWARE box, click WRITE. Do it twice. Then select the latest firmware release. Click WRITE. Uncheck the firmware box. Click WRITE. This should get the XBee alive again. Then you may make config changes as required, just watch that port speed, I've not been able to get my Series 1 higher than 9600 with any level of reliability.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.